Crashing application built from a KDevelop 1.6.0 template on Apple OSX

mk-lists at mk-lists at
Mon Mar 17 23:49:36 GMT 2014

Dear KDevelop-devs,

I have managed to install KDevelop 1.6.0 seamlessly via MacPorts on Mac OSX 10.9.2! 

First of all I have to say that I am impressed about how the application looks these days!
It is perhaps two years ago that I last checked it and tried to get going. Back then it didn’t work for me. :-(

	But now it seems that it is comparable to Qt-Creator already.
	I saw syntax-highlighted code with a ton of additional information about all the Qt and KDE classes, its documentation and alike… Great!!!


Since I am new to KDevelop I have a few questions:

The worst one concerns a crashing minimal app:

I set up projects via “Project/New From Template…/Project Type/Graphical” which could built the generated code (for “QML" as well as for "Minimal C++ KDE") with some warnings, but without a real error. :-)

When I now start either of the applications from the built app packages I unfortunately get one and the same error:
$ ./testgraphical
file:///Users/marko/projects/TestGraphical/build/src/ File not found 
Killed: 9

I am surprised to see a message like this on the console. What does this mean? Which file does the app try to load and why does it fail to do so?

KDevelop doesn’t allow me to step through the code in debug mode, so that I cannot say where exactly the issue occurred.

I could imagine that the app tries to access its configuration which is stored on MacOSX in ~/Library/Preferences/KDE :
$ pwd
$ ls -1
As one can see, kdevelop itself already stores its stuff in there. 

However, when I tried “Minimal C++ KDE” it worked! No crash, the application window came up. So, this points to some file access - which is not present in this minimal version because no complex configuration data is being read from somewhere...

Apart from these assumptions I am just clueless right now about how to further proceed. Hope you can push me into the right direction.

One question I’ve already addressed myself by joining [1].

The built app is below ./build/src and not ./build as one might perhaps expect. Is this a CMake issue?

Paths to KDE's header files are not known to the IDE. I needed to manually insert /opt/local/include/KDE in the config dialog popping up after clicking "Solve…”. I am sure this path can be handed over to KDevelop during the installation phase, right? When and how can I do that? Is there perhaps a CMake-parameter to be set already at configure time or is there somewhere a global configuration file which needs to be tweaked accordingly?

When trying to run a built app the configuration still doesn't know where the executable resides. One has to create a new configuration, search for the executable manually and only then you’re ready to go. Is that intentionally so? Couldn’t that be pre-created for a release and a debug configuration without user intervention at the time of project generation?

Aleix told me that Alexander is using KDevelop via homebrew. I hope he is listening in an could perhaps give some advice what I am dealing with here.

Best regards,


More information about the KDevelop mailing list