CMake 2.8.9 [WAS: Re: Working sets]

Milian Wolff mail at
Sun Dec 15 18:02:01 GMT 2013

On Saturday 14 December 2013 12:53:36 Michael George Hart wrote:
> Just did a git pull today
> When did cmake 2.8.9 become a requirement?


> Why is cmake 2.8.9 or higher a requirement?

B/C we use new features, specifically LINK_PRIVATE and LINK_PUBLIC, which I 
only found in the 2.8.9 documentation of CMake.

> 4/src/kdevelop> cd build/
> XMan at mecury:~/Documents/Projects/kdevelop4/src/kdevelop/build> cmake
> -DCMAKE_PREFIX_PATH=$HOME/bin/kdevelop4
> -DCMAKE_INSTALL_PREFIX=$HOME/bin/kdevelop4 ../
> CMake Error at CMakeLists.txt:10 (cmake_minimum_required):
>   CMake 2.8.9 or higher is required.  You are running version 2.8.8
> -- Configuring incomplete, errors occurred!

What distribution do you use? Even Debian stable has CMake 2.8.9 so I 

Also, what GCC/Clang do you use as we bumped the requirement to 4.8 and 3.1 
respectively for master.

If all this is too new for you, please stick to the just released 1.6/4.6 
version(s) and branches.

Milian Wolff
mail at

More information about the KDevelop mailing list