kdevelop and debug with libtool

dAgeCKo dagecko at free.fr
Fri Nov 9 19:20:31 GMT 2012


I was used to debug directly on the console. But now I'd like to use 
kdevelop to ease my life a bit since the programs I have to debug are 
quite big.

The project is a set of several libraries (.so) and several binary 
executable files, which, since I use libtool to create the libraries, 
are hidden in a subdirectory and replaced by a script file.
So, to debug them manually I usually enter such a command:

libtool --mode=execute gdb 'name_of_the_script'

I tried to make kdevelop does it this way, but failed all my attempts.

On the Internet, when searching, I could see that this is a common 
problem with Kdevelop since several years (I could saw topics from 2006 
for example, and Kdevelop 3.x series).

So, is the problem still not solved ? How do people using kdevelop 
achieve to debug programs using libtool ? I can't beleive people here 
just use the console instead: it will make the debug tools from kdevelop 
quite useless, since, AFAIK, libtool projects are quite predominant over 
simple binary projects.

I don't want to do a make install before (this is quite an heavy task).

What I actually tried:

* entered the debugger executable as libtool --mode=execute gdb
-> nothing happens
* entered the debugger executable as a script which encapsulates the 
previous command
-> kdevelop complains that the executable is not in an executable format
-> use a debugging shell (bash) for the previous commands
-> fails


More information about the KDevelop mailing list