Custom make manager plugin does not load

Manoj Rajagopalan rajagopalan.manoj at
Fri Dec 10 23:06:46 GMT 2010

Thanks. I tried what you suggested but that too isn't working.
Basically, after a few uses, my KDevelop app crashes. And subsequent
invocations give me this message upon startup. Why would this happen
after a couple of uses? Does the crash cause some corruption of
application data in the .kde/share/apps/kdev* directories?


On Fri, Dec 10, 2010 at 10:45 AM, Milian Wolff <mail at> wrote:
> On Thursday 09 December 2010 18:52:30 Manoj Rajagopalan wrote:
>> Hi,
>>    I just built KDevelop 4.1.0 on KUbuntu 10.04 and imported a custom
>> Makefile project. It worked fine yesterday immediately after the build and
>> install but this morning, at startup, I receive the error message:
>>    "project importing plugin (KDevCustomMakeManager) does not support the
>> IProjectFileManager interface"
>>    Now, the Import Project dialog fails to list Makefile based options.
>> When I select my custom Makefile project from the  "Recent Projects" menu,
>> I get the above error message again.
>> I have KDEDIRS=/usr:/usr/local in my .bashrc (and am invoking kdevelop from
>> commandline). kdevplatform and kdevelop have been installed to /usr/local.
> Bash != KDE. Put this also into an executable script in ~/.kde/env and then it
> should work. Or only use bash and run kbuildsycoca4 after you set that path,
> much slower though.
>>   I did make uninstall and then built and installed kdevelop 4.1.1 (and
>> kdevplatform 1.1.1) and the problem still persists.
>> Any hints?
> Bye
> --
> Milian Wolff
> mail at
> _______________________________________________
> kdevelop mailing list
> kdevelop at

More information about the KDevelop mailing list