kdevelop broken?

Andreas Pakulat apaku at gmx.de
Sat Aug 13 12:40:22 BST 2005

On 13.Aug 2005 - 12:16:33, Andreas Pakulat wrote:
> I just did svn up for kdevelop
> (anonsvn.kde.org/home/kde/branches/KDE/3.5/kdevelop) and the build stops
> in lib/catalog, because it seems there is some stuff missing in bdb:
> make[3]: Gehe in Verzeichnis »/home/andreas/compiling/kdevelopcvs/kdevelop/lib/catalog«
> if /bin/sh ../../libtool --silent --mode=compile --tag=CXX g++-3.3 -DHAVE_CONFIG_H -I. -I. -I../.. -I/usr/include/kde -I/usr/share/qt3/include -I/usr/X11R6/include   -DQT_THREAD_SUPPORT  -D_REENTRANT  -Wno-long-long -Wundef -ansi -D_XOPEN_SOURCE=500 -D_BSD_SOURCE -Wcast-align -Wconversion -Wchar-subscripts -Wall -W -Wpointer-arith -g -O2 -Wformat-security -Wmissing-format-attribute -Wno-non-virtual-dtor -fno-exceptions -fno-check-new -fno-common -DQT_CLEAN_NAMESPACE -DQT_NO_ASCII_CAST -DQT_NO_STL -DQT_NO_COMPAT -DQT_NO_TRANSLATION  -MT tag.lo -MD -MP -MF ".deps/tag.Tpo" -c -o tag.lo tag.cpp; \
> then mv -f ".deps/tag.Tpo" ".deps/tag.Plo"; else rm -f ".deps/tag.Tpo"; exit 1; fi
> if /bin/sh ../../libtool --silent --mode=compile --tag=CXX g++-3.3 -DHAVE_CONFIG_H -I. -I. -I../.. -I/usr/include/kde -I/usr/share/qt3/include -I/usr/X11R6/include   -DQT_THREAD_SUPPORT  -D_REENTRANT  -Wno-long-long -Wundef -ansi -D_XOPEN_SOURCE=500 -D_BSD_SOURCE -Wcast-align -Wconversion -Wchar-subscripts -Wall -W -Wpointer-arith -g -O2 -Wformat-security -Wmissing-format-attribute -Wno-non-virtual-dtor -fno-exceptions -fno-check-new -fno-common -DQT_CLEAN_NAMESPACE -DQT_NO_ASCII_CAST -DQT_NO_STL -DQT_NO_COMPAT -DQT_NO_TRANSLATION  -MT catalog.lo -MD -MP -MF ".deps/catalog.Tpo" -c -o catalog.lo catalog.cpp; \
> then mv -f ".deps/catalog.Tpo" ".deps/catalog.Plo"; else rm -f ".deps/catalog.Tpo"; exit 1; fi
> /bin/sh ../../libtool --silent --mode=link --tag=CXX g++-3.3  -Wno-long-long -Wundef -ansi -D_XOPEN_SOURCE=500 -D_BSD_SOURCE -Wcast-align -Wconversion -Wchar-subscripts -Wall -W -Wpointer-arith -g -O2 -Wformat-security -Wmissing-format-attribute -Wno-non-virtual-dtor -fno-exceptions -fno-check-new -fno-common -DQT_CLEAN_NAMESPACE -DQT_NO_ASCII_CAST -DQT_NO_STL -DQT_NO_COMPAT -DQT_NO_TRANSLATION    -o libkdevcatalog.la -rpath /home/andreas/kdevelop3.2.0/lib -no-undefined -Wl,--no-undefined -Wl,--allow-shlib-undefined -L/usr/lib -L/usr/share/qt3/lib -L/usr/X11R6/lib    -L../../bdb/dist tag.lo catalog.lo -ldb -lkdecore -lqt-mt  -lz -lpng -lz -lm -lXext -lX11  -lSM -lICE -lpthread
> ../../libtool: line 1586: cd: ../../bdb/dist: No such file or directory
> libtool: link: cannot determine absolute directory name of `../../bdb/dist'
> Or it's the other way and catalog's Makefile needs an update? I already
> tried make distclean and a fresh run of
> make -f Makefile.cvs
> configure
> make
> still the same problem :-(

And tried a re-checkout, still the same thing :-(


That secret you've been guarding, isn't.

to unsubscribe from this list send an email to kdevelop-request at kdevelop.org with the following body:
unsubscribe »your-email-address«

More information about the KDevelop mailing list