Problems with am_edit

Alexandros Karypidis karypid at inf.uth.gr
Thu May 27 10:59:30 UTC 2004


Darn! Just after posting I figured out why it no longer worked. I was 
trying it from within the "debug" build configuration. Apparently the 
makefiles generated assume that "make dist" will only be run from 
within tha base directory (topsrcdir). Is this a "bug" or is there some 
reason for it?

On Thursday 27 May 2004 13:35, Alexandros Karypidis wrote:

> I know the basics of automake but had never heard of am_edit. From
> what I've found on the web, my understanding is that it patches
> makefiles by creating proper rules for auto-generated sources.
>
> Anyway, my problem is that I have an application written with
> KDevelop, which I've been messing around with for a while in order to
> learn a few things about the KDE API. "make dist" now fails with:
>
> ---
> cd . && perl admin/am_edit -padmin
> Can't open perl script "admin/am_edit": No such file or directory
> make[1]: *** [dist-hook] Error 2
> ---
>
> This used to work in the past (actually there was a menu choice in
> the build menu which I can no longer locate and am therefore running
> this manually), but somewhere along my line of updates it ended up
> being broken.
>
> I then tried doing this: created a brand new project (Simple KDE
> Application) and ran "make dist" on it. Same thing. What gives?

-- 
In theory, there is no difference between theory and practice.
In practice, there is. -- Yogi Berra.

Alexandros Karypidis
University of Thessaly
Computer & Communications Engineering dept.

-
to unsubscribe from this list send an email to kdevelop-request at kdevelop.org with the following body:
unsubscribe »your-email-address«



More information about the KDevelop mailing list