zlib/libz not found

Steven Robson s.a.robson at sms.ed.ac.uk
Sun Feb 8 18:24:33 UTC 2004

Hi there,

(Using Slackware 9.1, kernel 2.4.24, Kdevelop 3.0.0)

I'm trying to compile several applications. They were all made with kdevelop
(they all have kdevelop project files). 
Some I have created as a test (eg new project, "simple kde application"),
Others are downloaded, eg kile. 
I can compile apps which do not appear to be created with kdevelop. 

They all fail on ./configure with:

checking for libz... configure: error: not found.
          Possibly configure picks up an outdated version
          installed by XFree86. Remove it from your system.

          Check your installation and look into config.log

I've checked that I have zlib and libz. config.log shows that it's looking
for zlib.h. It is there, in several different places. I've tried replacing
the one in the X11 include directories. 
I've also tried specifying it with ./configure
--includedir=/usr/include (where zlib.h is)  and

I've also tried updating zlib, to 1.2.1. It made no difference. 
I had the same problem with both kde 3.2 and 3.1.4

I'm now stuck as where to look next

Many thanks in advance to anyone who can help me


to unsubscribe from this list send an email to kdevelop-request at kdevelop.org with the following body:
unsubscribe »your-email-address«

More information about the KDevelop mailing list