problems with language translation

Mathias-H. Weber m-h.w at web.de
Wed Jan 29 17:57:16 UTC 2003


Am Mittwoch, 29. Januar 2003 17:02 schrieben Sie:
> I run kdevelop 2.1.5 on kde 3.1, but had the same problem with older
> versions. I also posted on this list time ago, but sorry it still does not
> work. I cannot do the "make messages and merge" step. allways i get the
> error: "msgmerge: could not open project.pot for read: file not found"
> (tranlated from german). Now indeed there is no such file, my project is no
> kde core application, just a tool. I already replaced the admin
> subdirectory by a copy from a new generated dummy project, no avail. Sorry
> for asking silly questions, all other parts of kdevelop work great for me.
> Regards Eggert

I cam across the same problem and had no clue what the hack the problem was! I 
dug deep into the gory details of the admin directory and finally commented 
out one line in the cvs.sh:

-------------------8<----------------------------------------------------------------
for i in `ls -1 po/*.pot 2>/dev/null | sed -e "s#po/##"`; do
  egrep -v '^#([^:]|$)' po/$i | egrep '^.*[^ ]+.*$' | grep -v "\"POT-Creation" 
> po.backup/$i
  cp po/$i po.backup/backup_$i
  touch -r po/$i po.backup/backup_$i
#MW: added following line
  echo "Removing po/$i"
#MW: Commented out following line
#  rm po/$i
done
------------------->8----------------------------------------------------------------

I have no idea what the intention of the line is and why it once worked. But 
without this line I can at least built my project successfully!

If anybody can really solve the problem (and not only show a workaround) I am 
heavily interested!

Mathias

-
to unsubscribe from this list send an email to kdevelop-request at kdevelop.org with the following body:
unsubscribe »your-email-address«



More information about the KDevelop mailing list