KDevelop 2.1..2: How to link to SDL?

Bettina Rathmann B.Rathmann at ping.de
Fri Sep 20 16:41:03 BST 2002

Hi all,

I have a simple problem which simply drives me nuts. I'm using using
KDevelop 2.1.2 on KDE 2.2.1 (Suse 7.3). I have a simple programme which
is intended to drive input and output via SDL. Although I'm quite
experienced with SDL this is the first time I tried to use it in
It seems impossible to me. What do I do to add SDL to link in Kdevelop?
1. Projects -> Options
2. Compiler settings. Tab Flags and warnings
   adding the correct include path to "C++ compiler flags"
   (as its and C++ project): "-I/usr/include/SDL"
3. Changing to "Linker Options", I add "-lSDL -lpthread" to
   "other libs" and accept the changes via "OK"
4. Build -> DistClean
5. Build -> Automake / Autoconf
6. Build -> Configure (only with suggested params by KDevelop)

Everything is fine up to now. Now for some compiling. Everything fine
too. But then the make process calls libtool to finally 
create the programme. This is the output:
/bin/sh ../libtool --mode=link --tag=CXX g++  -O2 -O0 -g3 -Wall
-I/usr/include/SDL -fno-exceptions -fno-check-new   -o diablo  
cl2object.o frame.o framecel.o framecl2.o gfx.o mpq.o celobject.o main.o
-lSDL -lpthread 
mkdir .libs

g++ -O2 -O0 -g3 -Wall -I/usr/include/SDL -fno-exceptions -fno-check-new
-o diablo cl2object.o frame.o framecel.o framecl2.o gfx.o mpq.o
celobject.o main.o  /usr/lib/libSDL.so -lm /usr/lib/libasound.so
-L/opt/kde2//lib -ldl -lartsc -L/usr/lib -lesd -laudiofile -lm
-L/usr/X11R6/lib -lX11 -lXext -lXxf86vm -lXxf86dga -lXv -ldl -lpthread
/usr/i486-suse-linux/bin/ld: cannot find -lesd
collect2: ld returned 1 exit status

And this is what drives me nuts: I don't need all those libs which
libtools adds to the linking line. I don't even have esd installed.
Whatever I tried, I can't figure out, how to get KDevelop / libtool to
stop trying. Help would be much appreciated. (I have looked in
Makefile.am / configure.in 
whether I could manually could change something there. esd cannot be
found. And instead of 3) I even tried to add the libs to to Linkertab of
2). The results are the same as above).

Please CC me, as I'm not on this list.

Thank you very much in advance

to unsubscribe from this list send an email to kdevelop-request at kdevelop.org with the following body:
unsubscribe »your-email-address«

More information about the KDevelop mailing list