Bug-report: KDevelop 2.1.2 crashes at Build->Autoconf/Automake

Jens Zurheide jens.zurheide at gmx.de
Sun Jul 7 22:28:25 UTC 2002


Sunday 07 July 2002 23:20 thomas.friedrichsmeier at ruhr-uni-bochum.de
>Version: Kdevelop 2.1.2
>Dist: SuSE 7.3
>automake: 1.4-p5
>autoconf: 2.5.2
>(both as distributed with SuSE 7.3)
>
>Description:
>KDevelop crashes when choosing Build->Autoconf/Automake. It also crashes
>during Disclean/Rebuild All and when "regenerating Makefiles". It crashes
>every time (tried around 8 times, even with a reboot in between).
>The problem occured after I upgraded to 2.1.2 and disappeared when I
>downgraded to 2.1 again. It does not seem to be related to a specific
> project (Tried it on two different ones).
>
>Sincerely,
>Thomas Friedrichsmeier
>
I have exactly the same problem. My backtrace is: 
#4  0x414d2bc4 in pthread_sighandler () from /lib/libpthread.so.0
#5  <signal handler called>
#6  0x40f85a4b in QTextFormatterBreakInWords::format (this=0x8310ba8, 
    doc=0x8310100, parag=0x84a5418, start=0) at kernel/qrichtext.cpp:5522
#7  0x40f7d96b in QTextParag::format (this=0x84a5418, start=-1, doMove=true)
    at kernel/qrichtext.cpp:3994
#8  0x41050d3c in QTextEdit::formatMore (this=0x830f118)
    at widgets/qtextedit.cpp:2121
#9  0x4104db63 in QTextEdit::ensureCursorVisible (this=0x830f118)
    at widgets/qtextedit.cpp:1573
#10 0x41056999 in QTextEdit::append (this=0x830f118, text=@0xbfffe824)
    at widgets/qtextedit.cpp:3677
#11 0x0811c679 in CMakeOutputWidget::insertAtEnd (this=0x830f118, 
    text=@0xbfffe858, defaultType=Normal)
    at /usr/local/kde/source-cvs/kdevelop-2.1/kdevelop/coutputwidget.cpp:159
#12 0x080b73a2 in CKDevelop::slotReceivedStdout (this=0x82af588, 
    buffer=0xbfffe99c "\nêÿ¿e ?A,\216 \bÌéÿ¿\004", buflen=1)
    at /usr/local/kde/source-cvs/kdevelop-2.1/kdevelop/ckdevelop.cpp:3358
#13 0x0817fcb8 in CKDevelop::qt_invoke (this=0x82af588, _id=304, 
_o=0xbfffe91c)
    at ckdevelop.moc.cpp:1147
#14 0x40f30662 in QObject::activate_signal (this=0x82af778, clist=0x83cae68, 
    o=0xbfffe91c) at kernel/qobject.cpp:2080
#15 0x40af17ee in KProcess::receivedStdout (this=0x82af778, t0=0x82af778, 
    t1=0xbfffe99c "\nêÿ¿e ?A,\216 \bÌéÿ¿\004", t2=1) at kprocess.moc:151
#16 0x40af078e in KProcess::childOutput (this=0x82af778, fdno=15)
    at /usr/local/kde/source-cvs/kdelibs/kdecore/kprocess.cpp:598
#17 0x40af05f3 in KProcess::slotChildOutput (this=0x82af778, fdno=15)
    at /usr/local/kde/source-cvs/kdelibs/kdecore/kprocess.cpp:533
#18 0x40af1b14 in KProcess::qt_invoke (this=0x82af778, _id=2, _o=0xbfffeea0)
    at kprocess.moc:200
#19 0x40af1d7e in KShellProcess::qt_invoke (this=0x82af778, _id=2, 
    _o=0xbfffeea0) at kprocess.moc:285
#20 0x40f30662 in QObject::activate_signal (this=0x8515650, clist=0x84b72a8, 
    o=0xbfffeea0) at kernel/qobject.cpp:2080
#21 0x40f30832 in QObject::activate_signal (this=0x8515650, signal=2, 
param=15)
    at kernel/qobject.cpp:2130
#22 0x411b979a in QSocketNotifier::activated (this=0x8515650, t0=15)
    at .moc/debug-mt/moc_qsocketnotifier.cpp:84
#23 0x40f4b3ba in QSocketNotifier::event (this=0x8515650, e=0xbffff0d8)
    at kernel/qsocketnotifier.cpp:249
#24 0x40ee7dd9 in QApplication::internalNotify (this=0xbffff28c, 
    receiver=0x8515650, e=0xbffff0d8) at kernel/qapplication.cpp:2306
#25 0x40ee72c0 in QApplication::notify (this=0xbffff28c, receiver=0x8515650, 
    e=0xbffff0d8) at kernel/qapplication.cpp:2117
#26 0x40ab5c65 in KApplication::notify (this=0xbffff28c, receiver=0x8515650, 
    event=0xbffff0d8)
    at /usr/local/kde/source-cvs/kdelibs/kdecore/kapplication.cpp:556
#27 0x4129728c in QApplication::sendEvent (receiver=0x8515650, 
    event=0xbffff0d8) at .moc/debug-mt/../../kernel/qapplication.h:452
#28 0x40e8ef61 in sn_activate () at kernel/qapplication_x11.cpp:3084
#29 0x40e8f5f4 in QApplication::processNextEvent (this=0xbffff28c, 
    canWait=true) at kernel/qapplication_x11.cpp:3273
#30 0x40ee9a64 in QApplication::enter_loop (this=0xbffff28c)
    at kernel/qapplication.cpp:3180
#31 0x40e8efdb in QApplication::exec (this=0xbffff28c)
    at kernel/qapplication_x11.cpp:3123
#32 0x080fa252 in main (argc=1, argv=0xbffff404)
    at /usr/local/kde/source-cvs/kdevelop-2.1/kdevelop/main.cpp:207
#33 0x415307ee in __libc_start_main () from /lib/libc.so.6
Around frame #12 there is garbled output to be displayed. The strange thing 
is that if I run kdevelop in the debugger of kdevelop this step works fine, 
but then receivedStdout() is called by childHasFinished() instead of 
childOutput().
Another thing that drives me crazy is that the F3 key does not work and I 
have no clue why. Debugging through the code it seems that the accelerator 
for this key must be removed completely from the list. Even assigning a 
different shortcut does not trigger calling the funciton  
QAccel::shortcutKey( const QString &str ). Does anybody have a clue here?
I found a line:
	kdecore (KAccel): WARNING: Sym::initQt( 3788 ): failed to convert key. 
and I think the lines
  accel->insertItem(i18n("Load tags file"), "LoadTagsfile", 
ID_PROJECT_LOAD_TAGS);
  accel->connectItem("LoadTagsfile", m_pParent, SLOT(slotProjectLoadTags() 
), true, ID_PROJECT_LOAD_TAGS );
are causing this problem.

Regards,
Jens

PS: valgrind -v kdevelop yields some interesting insights ;)



-
to unsubscribe from this list send an email to kdevelop-request at kdevelop.org with the following body:
unsubscribe »your-email-address«



More information about the KDevelop mailing list