KDevelop hangs when adding files & some questions

Reiner Beck r.beck at m4com.de
Mon Jul 1 15:52:45 UTC 2002


I posted part of this in the Forum as well, but the mailing list seems to be
more appropriate ...

Hello,
1) Bug:
after creating a new Project (Terminal C++) I tried to add headers and
sources to this project. First, I created a new subdirectory with KDevelop,
because I want to build a library. Then I chose "Project/Add existing
Files", select a number of files (*.h) and press OK. After adding a few
files, KDevelop hangs forever; the KDevelop and the "Please Wait" windows
don't refresh ...
This happens both if I copy the files into the lib-directory first, or if I
leave them in the original directory.

A "ps -ef | grep kdevelop" shows a running kdevelop and a "kdeinit: kio_file
file /tmp/ksocket-wally/xxx /tmp/ksocket-wally/yyy"
(longer names replaced by xxx, yyy).
KDevelop prints a number of "kdevelop: WARNING: No class by the name xxx
found" before hanging (don't know if there's a connection).

Adding each file individually works (but to add 40+ files each to 20+
projects sucks) ...

2) Question
In addition, I would like to get some advice how to port old KDevelop 1.2
projects to the new version. It seems that the old projects are not
compatible to the new version of KDevelop (e.g. my old projects don't have
an admin directory). I tried to downgrade autoconf from version 2.52 to
2.13, but no success. (I'm back to 2.52 now). Further, I get funny messages
(sometimes) when setting "Project/Options/Make Options/additional options"
to "install": calling "Build/autoconf and automake" results (sometimes) in a
> gmake: *** No rule to make target `install'. Stop.
> *** failed ***
message. But I need to install my libs etc. to make them visible to other
projects ...
Advice?!

3) Configure / Install Problem
Since this version of KDevelop, my programs install as "i386-linux-progname"
into the bin directory (where progname is replaced by the "real" program
name:).  This is annoying! How can I change this behaviour? I just want my
programs installed as "progname"!

4) Inconsistency in Project Options
It seems a little strange to me, that I have to set some "Linker Flags" in
the Compiler Options tab, while there's a Linker Option tab ...

Configuration:
Suse 8.0, updated with Suse YOU to the version shown below.
The originally installed KDevelop 2.1 which came with Suse 8.0 showed the
same behaviour.

> kdevelop -version
Qt: 3.0.3
KDE: 3.0.1
KDevelop: 2.1.1

Cheers
Reiner


-
to unsubscribe from this list send an email to kdevelop-request at kdevelop.org with the following body:
unsubscribe »your-email-address«



More information about the KDevelop mailing list