Not able to compile Kdevelop

W. Tasin tasin at
Mon Feb 4 01:05:47 GMT 2002

  Raffaele Sandrini wrote:

>>and what do you mean with release of KDevelop?
>>With QT 2.2.2 and kde 2.2.2 KDevelop from CVS (branch KDE_2_2_BRANCH)
>>compiles perfectly.
>>I'm now trying the same KDevelop with admin-dir (from HEAD) and the
>>actual cvs-kde (HEAD branch), with qt-copy, but it takes a little bit
>>compiling qt-copy, kdelibs and kdevelop.
>>So under which conditions do this happen?
>Ok. I have use qt-copy (actaully QT 3.0.2) and CVS HEAD KDE. First i tried to 
>compile CVS HEAD Kdevelop. That failed.
Ok... cvs HEAD Kdevelop is gideon. I cannot tell you if there is a 
problem with qt 3.0.2 (or newer autotools) usage... I want pass this to 
our gideon specialists.

But I think you want to use KDevelop 2.1beta2 branch with KDE3beta and 
qt 3.0.2.
So please checkout KDevelop CVS KDE_2_2_BRANCH delete the admin 
directory copy or link the recent admin dir to the toplevel directory of 
kdevelop and begin to build.

So here are the steps abbreviated:
#cvs co -rKDE_2_2_BRANCH kdevelop
#cvs co kde-common
#cd kdevelop
#rm admin -r
#ln -s ../kde-common/admin admin
#make -f Makefile.cvs
#configure .....
#su -c "make install"

>Then i took the release wich i found in the stable section of the kde ftp 
>server. File name is: kdevelop-2.1beta_for_KDE_3.0.tar.bz2
>I tried to compile under same conditions and it failed...
This should work...
at least it works on my machine ;-).


The KDevelop project: tasin at []
oohhh sveglia.... il mondo e' ammalato, ma x colpa di chi.........
:-------W. Tasin, FB 04,FHM-------------------PGP-KeyID:0x7961A645----------:
<Key-Fingerprint: 1610 835F 0080 32F4 6140  6CF7 A7D0 44CD 7961A645>

to unsubscribe from this list send an email to kdevelop-request at with the following body:
unsubscribe »your-email-address«

More information about the KDevelop mailing list