Internal debuger doesn't work in a project

Werner Modenbach modenbach at alc.de
Tue Jun 19 19:02:23 UTC 2001


Hi everybody,

I'm confused about a behavior I cant understand.
I'm using kdevelop 1.4 on kde 2.1 /qt 2.2.4.

Some time ago I worked on a pure C project and everything worked fine - 
including debuging with the internal debuger.
Now I have to do improvements and I can't get the debuger working.
I put breakpoints on the first statements of main() but the program runs to 
the end without reaching the breakpoints. I can put many breakpoints at many 
places but none of them is ever reached.

When I interrupt the program in a waiting readcall (i.e. read in libc called 
by getc() ) I can see the frame stack. After entering a keystroke an 
proceding debuging by "leave procedure" I finaly get back to main() but the 
status line tells me something like "no source for main.c".

What happened? How can I get things working again?

Thanks for any help.

- Werner -

BTW Debugging in my QT projects works still fine.

-- 
--------------------------------------------------------------
                    ALC Computertechnik GmbH

        \_       \_          \_\_\_     Kaiserstr. 100
       \_\_      \_        \_           D-52134 Herzogenrath
      \_  \_     \_        \_           Germany
     \_\_\_\_    \_        \_           Fon +49 2407 95810
    \_      \_   \_        \_           Fax +49 2407 958139
   \_        \_  \_\_\_\_    \_\_\_     http://www.alc.de
   ===========================================================
   Werner Modenbach                     modenbach at alc.de
--------------------------------------------------------------

-
to unsubscribe from this list send an email to kdevelop-request at kdevelop.org with the following body:
unsubscribe »your-email-address«



More information about the KDevelop mailing list