Updated to KDE 2 beta4 and can no longer build kde2 projects?

Ralf Nolden nolden at kde.org
Tue Aug 29 07:18:53 UTC 2000


Frank Nichols wrote:
> 
> Okay,
> 
> I am stupid - a long time ago I installed kdevelop and played with it a bit,
> then I upgraded to kdevelop-1.2-3. And I think I tried building a test KDE2
> MDI project and it worked.  Now recently I upgraded to KDE2 beta4 and decided
> to get a bit more serious about a couple kde projects. So, I cranked up
> kdevelop and created a kde2 mdi project using the wizard. When I try to build
> it I get a few errors trying to compile the test.cpp.
> 
> It starts with:
> 
> test.cpp: In method 'TestApp::TestApp()':
> test.cpp 43: no matching function for call to 'KApplication::config()'

use getConfig() I think. If in doubt, generate the kde api docs and look
for KApplication in kdeui.
Seems this has to be updated as well.

Ralf
-- 
The only way to get rid of a temptation is to yield to it. Oscar Wilde

**********************************
Ralf Nolden

The KDevelop Project
http://www.kdevelop.org

nolden at kde.org
rnolden at kdevelop.org
**********************************




More information about the KDevelop mailing list