Updated to KDE 2 beta4 and can no longer build kde2 projects?

Frank Nichols frank at theNichols.net
Mon Aug 28 17:55:40 UTC 2000


Okay, 

I am stupid - a long time ago I installed kdevelop and played with it a bit, 
then I upgraded to kdevelop-1.2-3. And I think I tried building a test KDE2 
MDI project and it worked.  Now recently I upgraded to KDE2 beta4 and decided 
to get a bit more serious about a couple kde projects. So, I cranked up 
kdevelop and created a kde2 mdi project using the wizard. When I try to build 
it I get a few errors trying to compile the test.cpp. 

It starts with:

test.cpp: In method 'TestApp::TestApp()':
test.cpp 43: no matching function for call to 'KApplication::config()'

And then goes on for several pages. I expect I have the wrong includes now?

The compile line looks like:

g++ -DHAVE_CONFIG_H -I. -I. -I.. -I/opt/kde/include -I/opt/kde2//include 
-I/usr/X11R6/include -O0 -g3 -Wall -c test.cpp

(The double slashes in -I/opt/kde2//include are there - I don't recall if 
Linux cares, I changed it in the make file and it didn't help)

I am running SuSE 6.4 with both KDE2 and HELIX Gnome installed.

Any suggestions?

TIA

Frank Nichols

-- 
while( ! world->perfect ) {
    whine();
}




More information about the KDevelop mailing list