KDevelop 2.0 crash on "File->New"

Shane Rogers srogers at pittstate.edu
Tue Apr 25 19:30:45 UTC 2000


On Tue, 25 Apr 2000, you wrote:
> > Program received signal SIGSEGV, Segmentation fault.
> > 0x4080ca89 in QString::QString ()
> Do you use a current qt-copy (uses Qt-2.1)?
> Update your cvs version of kde2 and kdevelop2 (cvs-modules:
> kde-qt-addon, kdesupport, kdelibs, kdevelop) and recompile all in this
> way:

Yes my qt-copy is current with what is in the HEAD branch, I update everything
every couple of hours for my local mirror and then use cvsup from that to
update kde-common, kde-qt-addon, kdebase, kdelibs, kdesupport, qt-copy, 
kdevelop, etc.  So everythings current.

> 
> cvs update
> -P -d

I use CVSup, so I don't think that applies.

> export QTDIR=....
> export KDEDIR=....
> export LD_LIBRARY_PATH=$QTDIR/lib:$KDEDIR/lib
> export LIBRARY_PATH=$QTDIR/lib:$KDEDIR/lib

I have these set correctly.

> make -f admin/Makefile.common cvs-clean

Again, CVSup so this is not usable.

> make -f Makefile.cvs
> ./configure
> make
> su
> make install

That's pretty much what I do:

export MAKE='make -j 3'
make -f Makefile.cvs
./configure --prefix=/opt/kde2 --enable-fast-perl
make
su
make install

>  
> This should work. Anyway it worked for me yesterday.

All other KDE2 stuff works pretty much, just not kdevelop for some reason.
I'm recompiling again after another cvsup and 'make clean', I doublechecked my
environment settings again to make sure they were good (LD_LIBRARY_PATH was
off, but still worked, and LIBRARY_PATH was not set at all).  We'll see if
there is any change.

-- 
Shane Rogers                                 .-------------------------.
Information Resource Specialist              |   Linux,                |
Pittsburg State University, Pittsburg KS     |      one less thing     |
srogers at pittstate.edu                        |         to worry about. |
swrogers at chanute-ks.com                      ._________________________.




More information about the KDevelop mailing list