Qt strikes again

OS owensavill at compuserve.com
Tue Apr 18 23:19:56 UTC 2000


Good stuff, this got me past the Qt problem.

Why is this a project setting. Surely this is a global property. After all as
we all know, if it cannot find Qt it stops dead in its tracks.

Now it fails because on the fourth time of checking that gcc will compile it
finds it doesn't ! Funny, it passed the previous three checks. I will go back
over archived gcc's to see if I can find one that works. I had given up with
egcs and pgcc, these stopped working with kdevelop a long time ago ! Maybe I'll
give them another go.

Regards,
Owen

On Fri, 14 Apr 2000, you wrote:
> OS wrote:
> > Please, please, please , please , please , please , please , please , please ,
> > please , please , please , please , please , please , please , please  give us
> > some way of telling kdevelop where the Qt libraries are installed.
> 
> -create your project with the appwizard (yes, the qt´s won´t be found, I
> know)
> -Build->Configure
> -enter: --with-qt-dir=/path_to_qt_dir
> -Press OK 
> 
> Then the Qt libs and includes should be found by configure
> 
> REMOVE config.cache BEFORE in the RFV
> 
> 
> RalfOS wrote:
> > 
> > Hello,
> > 
> > It seems the only time I ever e-mail kdevelop these days is because of the
> > perenial Qt not found problem !
> > 
> > This says a lot for kdevelop, but this Qt issue is an oldie and a complete
> > stumper. Without Qt everything just stops !
> > 
> > I had a hard disc crash and had to re-install everything, so I am now
> > using Mandrake 7, gcc  2.95.2-3mdk and Qt 1.44-20mdk.
> > 
> > I am currently using kdevelop 1.1
> > 
> > No surprise, kdevelop just stops whenever it tries to find the Qt libraries.
> > Once again there is no way of telling kdevelop where the Qt libraries are. Fine
> > for Qt2, I can tell it where they are, but Qt noooooo !
> > 
> > I have the environment variables set according to the many e-mails about this
> > problem in the past, but once again they don't work.
> > 
> > The old method of repeatedly re-installing random combinations of Qt, gcc,
> > kdevelop and even glibc no longer appears to work either.
> > 
> > Please, please, please , please , please , please , please , please , please ,
> > please , please , please , please , please , please , please , please  give us
> > some way of telling kdevelop where the Qt libraries are installed.
> > 
> > Regards,
> > Owen
> 
> 
> -- 
> Zladdi forever: Krisch Isch Plack !!
> 
> **********************************
> Ralf Nolden
> 
> Ardennenstr. 41 
> 52355 Düren
> 
> Tel. 02421/502758
> 
> The KDevelop Project
> http://www.kdevelop.org
> 
> Email: rnolden at kdevelop.de
> **********************************




More information about the KDevelop mailing list