D4772: projectmanagerview: Make cut-paste work by fixing project manager's Paste action
Alexander Potashev
noreply at phabricator.kde.org
Sun Mar 19 20:40:00 UTC 2017
aspotashev requested review of this revision.
aspotashev added inline comments.
INLINE COMMENTS
> mwolff wrote in cutcopypastehelpers.cpp:78
> add a TODO to create a model for the task list, and use it here instead of using QTreeWidget
Ok. But why using a model? QTreeWidget is enough for the current feature-poor widget.
> mwolff wrote in cutcopypastehelpers.cpp:78
> also here and elsewhere: do not use foreach, use range-based for
Ok. I couldn't find KDevelop coding style on the net, is it available?
> mwolff wrote in cutcopypastehelpers.cpp:186
> again return a struct, instead of using out parameters
ok
> mwolff wrote in cutcopypastehelpers.cpp:226
> add braces
Ok. Please add this to a coding style document.
> mwolff wrote in cutcopypastehelpers.cpp:337
> dialog->setAttribute(Qt::WA_DeleteOnClose);
> dialog->show();
Is this solution safe for this scenario -> https://blogs.kde.org/2009/03/26/how-crash-almost-every-qtkde-application-and-how-fix-it-0 ?
> mwolff wrote in cutcopypastehelpers.h:59
> rename to `mapSourceToDestination`, return a struct with the mapping instead of taking two out-parameters
>
> rename first `paths` argument to sourcePaths, rename `destPath` to `destinationPath`
ok
> mwolff wrote in cutcopypastehelpers.h:63
> please use an enum instead of a boolean here
Why? There are no other forthcoming options besides Cut and Copy. At least KIO::isClipboardDataCut() returns a boolean.
> mwolff wrote in cutcopypastehelpers.h:65
> rename to `showWarningDialogForFailedPaste`
ok
REPOSITORY
R33 KDevPlatform
REVISION DETAIL
https://phabricator.kde.org/D4772
To: aspotashev, kfunk, mwolff
Cc: kdevelop-devel
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.kde.org/pipermail/kdevelop-devel/attachments/20170319/d4771b2b/attachment-0001.html>
More information about the KDevelop-devel
mailing list