Review Request 115383: Reuse code in Refactor widget. Changes in kdevplatform

Milian Wolff mail at milianw.de
Wed Jan 29 16:36:31 UTC 2014


-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://git.reviewboard.kde.org/r/115383/#review48558
-----------------------------------------------------------


some small nitpicks, generally looks good though - thanks!


language/codegen/basicrefactoring.h
<https://git.reviewboard.kde.org/r/115383/#comment34312>

    put brace on newline



language/codegen/basicrefactoring.h
<https://git.reviewboard.kde.org/r/115383/#comment34320>

    here and below: use /**...*/ comments for multi-line api-dox please



language/codegen/basicrefactoring.h
<https://git.reviewboard.kde.org/r/115383/#comment34313>

    add trailing "s", i.e. renameCollectedDeclarations



language/codegen/basicrefactoring.cpp
<https://git.reviewboard.kde.org/r/115383/#comment34314>

    imo these temporary variables don't help readability, just use nc.newName / nc.collector.data directly where required here



language/codegen/basicrefactoring.cpp
<https://git.reviewboard.kde.org/r/115383/#comment34315>

    moving code around in the same patch makes it hard to review... please keep this in mind for future changes and submit first a cleanup patch, then the smaller patch which adds the functionality.



language/codegen/basicrefactoring.cpp
<https://git.reviewboard.kde.org/r/115383/#comment34316>

    just DUChainReadLocker lock;



language/codegen/basicrefactoring.cpp
<https://git.reviewboard.kde.org/r/115383/#comment34317>

    remove this line



language/codegen/basicrefactoring.cpp
<https://git.reviewboard.kde.org/r/115383/#comment34318>

    remove whitespace before &, same below



language/codegen/basicrefactoring.cpp
<https://git.reviewboard.kde.org/r/115383/#comment34319>

    return {} should suffice, no? also below



language/duchain/navigation/useswidget.h
<https://git.reviewboard.kde.org/r/115383/#comment34321>

    const& the declaration



language/duchain/navigation/useswidget.h
<https://git.reviewboard.kde.org/r/115383/#comment34322>

    this should get a big fat TODO comment that it should be ported to use shared ptr around m_collector - the api right now is really ugly imo - could you clean this up in a following patch please?


- Milian Wolff


On Jan. 29, 2014, 4:05 p.m., Sergey Kalinichev wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://git.reviewboard.kde.org/r/115383/
> -----------------------------------------------------------
> 
> (Updated Jan. 29, 2014, 4:05 p.m.)
> 
> 
> Review request for KDevelop.
> 
> 
> Repository: kdevplatform
> 
> 
> Description
> -------
> 
> Refactore code out a little bit so that language plugins can reuse even more code if they want to reimplement startInteractiveRename function.
> 
> 
> Diffs
> -----
> 
>   language/codegen/basicrefactoring.cpp d5e8c67 
>   language/duchain/navigation/useswidget.h f52d868 
>   language/duchain/navigation/useswidget.cpp 2fd0bd9 
>   language/codegen/basicrefactoring.h 06606a5 
> 
> Diff: https://git.reviewboard.kde.org/r/115383/diff/
> 
> 
> Testing
> -------
> 
> 
> Thanks,
> 
> Sergey Kalinichev
> 
>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.kde.org/pipermail/kdevelop-devel/attachments/20140129/1586c395/attachment-0001.html>


More information about the KDevelop-devel mailing list