Review Request: Document switcher plugin improvement

Jarosław Sierant jaroslaw.sierant at gmail.com
Mon Jan 7 20:06:38 UTC 2013


-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
http://git.reviewboard.kde.org/r/107628/
-----------------------------------------------------------

(Updated Jan. 7, 2013, 8:06 p.m.)


Review request for KDevelop.


Changes
-------

I attached a screenshot with document switcher based on QTableView.
QTableView provide simple way to calculate column width (through headers) but it has some drawbacks:
1. Window in most cases has to be bigger, especially if length of files names are different.
2. IMHO second column with the same paths doesn't look pretty (in the previous approach it looks much better).


Maybe previous approach with QListView is better.
I could only delete truncation of each subdirectory and set some max window width.
QListView will automatically elide line if it is to long.

What do you think?


Description
-------

Document switcher window width is automatically calculated base on content (auto adjust to longest item). Current screen width is upper bound of the window width.

Code duplication has been removed (methods walkForward/walkBackward).

A path to the file on items list can be truncated if it is too long (threshold=80).


Diffs
-----

  plugins/documentswitcher/documentswitcherplugin.h 0924e81 
  plugins/documentswitcher/documentswitcherplugin.cpp d457a5a 

Diff: http://git.reviewboard.kde.org/r/107628/diff/


Testing
-------

Only manual tests are done.


Screenshots (updated)
-----------

Document Switcher window based on QTableView
  http://git.reviewboard.kde.org/r/107628/s/990/


Thanks,

Jarosław Sierant

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.kde.org/pipermail/kdevelop-devel/attachments/20130107/366f7fca/attachment.html>


More information about the KDevelop-devel mailing list