Review Request: Proper auto-completion in switch statements
Olivier Jean de Gaalon
olivier.jg at gmail.com
Wed Jul 4 23:40:25 UTC 2012
-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
http://git.reviewboard.kde.org/r/105410/#review15389
-----------------------------------------------------------
I don't have time to do a proper review right now, but with a quick look-over... Once you've gone through the trouble of finding out what items are non-const, why bother demoting them? Is there a reason they should be included in the possible completions at all?
- Olivier Jean de Gaalon
On July 4, 2012, 9:49 a.m., Ivan Shapovalov wrote:
>
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> http://git.reviewboard.kde.org/r/105410/
> -----------------------------------------------------------
>
> (Updated July 4, 2012, 9:49 a.m.)
>
>
> Review request for KDevelop.
>
>
> Description
> -------
>
> Improve code completion within switch statements.
>
> 1) Resolve type of the switch'd expression correctly
> - in switchExpressionType(), replaced evaluateType() with evaluateExpression()
>
> 2) Correctly complete code for enumerations (e. g. do not mark type declarations as matching items)
> - this required adding integral constant check in CodeCompletionContext::standardAccessCompletionItems()
>
> 3) Add completion items for enumerations declared in different scopes
> - this required adding another condition branch in the end of CodeCompletionContext::standardAccessCompletionItems(),
> which in turn required proper setting of m_expressionResult in CaseAccess contexts,
> which required moving switchExpressionType() to doCaseCompletion() to avoid code duplication.
>
>
> Diffs
> -----
>
> languages/cpp/codecompletion/context.h a5fdea7
> languages/cpp/codecompletion/context.cpp 33dcad1
> languages/cpp/tests/test_cppcodecompletion.h 20a70cb
> languages/cpp/tests/test_cppcodecompletion.cpp ec82d2d
>
> Diff: http://git.reviewboard.kde.org/r/105410/diff/
>
>
> Testing
> -------
>
> there is a unit-test for change (1),
> I don't know how to test (2) and
> (3) cannot be tested due to some weird things with CompletionItemTester though it can be tested manually.
>
>
> Thanks,
>
> Ivan Shapovalov
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.kde.org/pipermail/kdevelop-devel/attachments/20120704/7395b542/attachment.html>
More information about the KDevelop-devel
mailing list