kdev-valgrind does not work with the latest build from trunk of kdevelop4 (4.3x)

Michael Hart michael.george.hart at gmail.com
Sun Feb 19 13:34:22 UTC 2012

Fantastic that little trick worked!!!! You might consider upgrading your
documentation to flag this potential issue in your FAQ section for those
people who build kdevelop4 and kdev-valgrind from source.

I tried the same thing for the python plugin. It also showed now shows up
in the "Help->Loaded Plugin" as "kdevpythonsupport" However, in
"Settings->Configure Kdevelop...->Plugin" there is not indication that
there exist a PYTHON plugin. Even more so Kdevelop4 has the same standard
behavior without the PYTHON Plugin.

You wouldn't off hand know what to do about that?

Thanks for the help with Valgrind. It is going to be a very useful addition
to work.


On Sun, Feb 19, 2012 at 3:07 AM, Damien Coppel <damien.coppel at gmail.com>wrote:

> Hi Michael.
> I think the problem come form a different version between kdevvalgrind and
> kdevelop.
> To get the correct version, you can for exemple check at the end of the
> file "kdevgdb.desktop" (probably
> "/home/me/bin/kdevelop4/share/kde4/services/kdevgdb.desktop").
> There is a line which looks like "X-KDevelop-Version=14".
> Then put the same numer on the line "X-KDevelop-Version=xx" of the file
> "kdevvalgrind.desktop"
> ("/home/me/bin/kdevelop4/share/kde4/services/kdevvalgrind.desktop").
> This version depend of the way you get kdevelop (git, package ...), so we
> stiil have some trouble to get it right in all the case.
> Then you have to run the command "kbuildsycoca4" in a terminal where the
> environment variable KDEDIRS is correctly set
> ("KDEDIRS=/home/me/bin/kdevelop4:/") before starting kdevelop (this command
> check all the available plugin).
> Let us know if it works !
> Regards.
> On Sun, Feb 19, 2012 at 7:44 AM, Michael Hart <
> michael.george.hart at gmail.com> wrote:
>> kdev-valgrind does not work with the latest trunk build kdevelop4 version
>> 3
>> I have down loaded the latest trunk of kdevelop4 and did the following
>> after building and testing kdevelop4
>> git clone git://anongit.kde.org/kdev-valgrind
>> cd kdev-valgrind
>> mkdir build
>> cd build
>> cmake -DCMAKE_INSTALL_PREFIX:PATH=/home/me/bin/kdevelop4 ../   "that is
>> where kdevelop is installed"
>> make
>> make install
>> Install the project...
>> -- Install configuration:
>> "RelWithDebInfo"
>> -- Up-to-date: /home/me/bin/kdevelop4/lib64/kde4/kdevvalgrind.so
>> -- Up-to-date:
>> /home/me/bin/kdevelop4/share/kde4/services/kdevvalgrind.desktop
>> -- Up-to-date:
>> /home/me/bin/kdevelop4/share/apps/kdevvalgrind/kdevvalgrind.rc
>> Any idea how to fix this I have checked several times and it clear it has
>> not been loaded. Nothing showing up in the configuration launcher either.
>> Any idea how to fix this?
>> Thanks
>> Michael
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.kde.org/pipermail/kdevelop-devel/attachments/20120219/378a0265/attachment.html>

More information about the KDevelop-devel mailing list