Review Request: Allow to pass multiple targets and build variables to the make builder

Alexandre Courbot gnurou at gmail.com
Sun Apr 15 06:44:28 UTC 2012



> On April 13, 2012, 9:27 p.m., Milian Wolff wrote:
> > projectbuilders/makebuilder/imakebuilder.h, line 26
> > <http://git.reviewboard.kde.org/r/104537/diff/2/?file=56290#file56290line26>
> >
> >     hm a QMap will implicitly sort the variables, that might not be desired. i.e. if you want to have
> >     
> >     make FOO=bar ASDF=asdf
> >     
> >     you will actually get
> >     
> >     make ASDF=asdf FOO=bar
> >     
> >     instead it might be better to just go for a QStringList of arguments, which would also allow stuff like
> >     
> >     make FOO BAR
> >     
> >     (i.e. not A=B but just A B)
> 
> Alexandre Courbot wrote:
>     These are variables, not no targets - their order do not matter, as they are just going to prevent same-name variables from being defined in the Makefile.
>     
>     http://ftp.gnu.org/old-gnu/Manuals/make-3.79.1/html_chapter/make_9.html#SEC90
>     
>     And as the same document says, the use of '=' is what differentiates a variable from a target in the command line. In your last example, FOO and BAR are targets, not variables. The order of targets does matter, but they already use a QStringList.
>     
>     So apart from a cosmetic point of view (QMap<QString, QString> might not be so elegant to have around, maybe a typedef would be better?), it seems to me that QMap is totally adequate here.
> 
> Andreas Pakulat wrote:
>     I agree with Alexandre, a quick test shows that variables on the commandline cannot reference each other so the order is completely irrelevant. In such a case a QMap is ok I believe and makes it easier to handle addition/removal. It should also be fast enough since there are not many variables set usually.
> 
> Milian Wolff wrote:
>     well, then this is OK with me

I will just add a typedef to make things easier to read.


> On April 13, 2012, 9:27 p.m., Milian Wolff wrote:
> > projectbuilders/makebuilder/imakebuilder.h, line 42
> > <http://git.reviewboard.kde.org/r/104537/diff/2/?file=56290#file56290line42>
> >
> >     please don't inline this (it's virtual anyways), put it into the .cpp file
> 
> Alexandre Courbot wrote:
>     There is no cpp file for IMakeBuilder yet, but ok.
> 
> Andreas Pakulat wrote:
>     If you're adding non-pure-virtual functions to IMakeBuilder you're doing the wrong thing already. The interface should not have any such functions, its just an API definition.
> 
> Milian Wolff wrote:
>     true, apaku has a point. leave the default-implementation to the implemenation, not to the interface.

How about IProjectBuilder, which also has implemented methods for e.g. configure()? I am fine with slipping these into the implementation, but this means code duplication if another implementation gets in. We are using C++, not Java - is there any *practical* reason to take interfaces so literally?


- Alexandre


-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
http://git.reviewboard.kde.org/r/104537/#review12409
-----------------------------------------------------------


On April 11, 2012, 2:13 a.m., Alexandre Courbot wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> http://git.reviewboard.kde.org/r/104537/
> -----------------------------------------------------------
> 
> (Updated April 11, 2012, 2:13 a.m.)
> 
> 
> Review request for KDevelop.
> 
> 
> Description
> -------
> 
> This change augments the IMakeBuilder interface and MakeBuilder class to let them support the following:
> 
> 1) Let make be run with multiple targets to build in one run
> 2) Pass build variables as a QMap of (variable, value) pairs that are also passed to make's command line.
> 
> E.g. this change now makes it possible for the make builder to perform make invokations that look like the following (example taken from an actual Linux kernel build):
> 
> $ make ARCH=arm CROSS_COMPILE=/usr/bin/arm-elf- vmlinux modules
> 
> API compatibility is not broken, but ABI is as the former virtual method of IMakeBuilder is now an inline function.
> 
> 
> Diffs
> -----
> 
>   projectbuilders/makebuilder/imakebuilder.h 56735425d78551883f109e942145eba2aa982687 
>   projectbuilders/makebuilder/makebuilder.h 34881c6eaee775b6b8b53959dfcf825732e806da 
>   projectbuilders/makebuilder/makebuilder.cpp 6c6905db30f469958f4a0048826febea29bad15a 
>   projectbuilders/makebuilder/makejob.h 19032fdf371da793d52b3457e5aa78a6b8458150 
>   projectbuilders/makebuilder/makejob.cpp ad5636dbfdadf3ae18ad1cc5b8dff078dd34cd42 
> 
> Diff: http://git.reviewboard.kde.org/r/104537/diff/
> 
> 
> Testing
> -------
> 
> Ensured API remained compatible and prior API behaved identically, tested build variables with the kdev-kernel plugin that uses them.
> 
> 
> Thanks,
> 
> Alexandre Courbot
> 
>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.kde.org/pipermail/kdevelop-devel/attachments/20120415/605a10ea/attachment.html>


More information about the KDevelop-devel mailing list