Review Request: Automatically resize VariableTooltip to fit its contents

Milian Wolff mail at milianw.de
Sun Apr 3 19:22:21 UTC 2011


-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
http://git.reviewboard.kde.org/r/101021/#review2365
-----------------------------------------------------------


a maximum otherwise looks fine and solves a real problem, thanks for taking care :D


debugger/util/treemodel.h
<http://git.reviewboard.kde.org/r/101021/#comment2034>

    strange name.
    
    childrenReady() maybe? or childrenFetched()?



debugger/util/treeview.cpp
<http://git.reviewboard.kde.org/r/101021/#comment2035>

    some sort of maximum should be put into place


- Milian


On April 3, 2011, 7:08 p.m., Dmitry Risenberg wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> http://git.reviewboard.kde.org/r/101021/
> -----------------------------------------------------------
> 
> (Updated April 3, 2011, 7:08 p.m.)
> 
> 
> Review request for KDevelop.
> 
> 
> Summary
> -------
> 
> When debug tooltip displays long names/values, I have to manually resize it to see all the info. This patch changes debug tooltip behaviour to automatically resize itself when items are expanded.
> 
> Also requires a small patch to kdevelop:
> 
> diff --git a/debuggers/gdb/gdbvariable.cpp b/debuggers/gdb/gdbvariable.cpp
> index ae65169..cab25a2 100644
> --- a/debuggers/gdb/gdbvariable.cpp
> +++ b/debuggers/gdb/gdbvariable.cpp
> @@ -223,6 +223,7 @@ public:
>  
>          variable->setHasMore(hasMore);
>          if (m_activeCommands == 0) {
> +            variable->emitAllChildrenFetched();
>              delete this;
>          }
>      }
> 
> P.S. Should this go to 4.2 or master?
> 
> 
> Diffs
> -----
> 
>   debugger/util/treeitem.h 94cd6dbc38d2ecdaaec2f7185201c00031752efd 
>   debugger/util/treeitem.cpp 7e0f6bc3c6eb70f31f1ae72d47610a58731f8cad 
>   debugger/util/treemodel.h e12e0161ba375526fb2cfe40ec166be4f332c448 
>   debugger/util/treemodel.cpp 6d53cb8776e54212e48e95690052eb007c69d03c 
>   debugger/util/treeview.h b0e32709a96732f404eb8ea587858536086527a0 
>   debugger/util/treeview.cpp 72f5567b73eea3e9fe4a72ced91882a0ce5be549 
>   debugger/variable/variabletooltip.cpp 1c3c537ccdd788aa4a3b4fcc0edd70fd121b2816 
> 
> Diff: http://git.reviewboard.kde.org/r/101021/diff
> 
> 
> Testing
> -------
> 
> Manual
> 
> 
> Thanks,
> 
> Dmitry
> 
>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.kde.org/pipermail/kdevelop-devel/attachments/20110403/62a51e44/attachment.html>


More information about the KDevelop-devel mailing list