extargear/sdk configuration problem

Andras Mantia amantia at kde.org
Thu Dec 3 07:27:29 UTC 2009


 if you try to build extragear/sdk as a module and you don't have 
kdevplatform built and installed yet, cmake configuration bails out with 
this error:
Make Warning at kdevelop/cmake/modules/FindKDevPlatform.cmake:41 
  Could not find a configuration file for package KDevPlatform.

  Set KDevPlatform_DIR to the directory containing a CMake configuration 
  for KDevPlatform.  The file will have one of the following names:


Call Stack (most recent call first):
  kdevelop/CMakeLists.txt:19 (find_package)

CMake Error at 
  Could NOT find KDevPlatform (missing: KDevPlatform_CONFIG)
Call Stack (most recent call first):
  kdevelop/CMakeLists.txt:19 (find_package)

I tried a 
in the toplevel CMakeList.txt, but didn't help. Tried to set 
CMAKE_MODULE_PATH to the same dir, again, without sucess

I don't consider myself a cmake expert, so I gave up at this point and 
built (and installed) kdevplatform first...

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 190 bytes
Desc: This is a digitally signed message part.
URL: <http://mail.kde.org/pipermail/kdevelop-devel/attachments/20091203/e13480d4/attachment.sig>

More information about the KDevelop-devel mailing list