Name for test subsystem

David Nolden zwabel+kde at
Sun Jun 22 10:43:15 UTC 2008

Am Sonntag, 22. Juni 2008 10:29:11 schrieb Manuel Breugelmans:
> Hmmkay I suppose it could get confusing for some. The current 'xTest' it is
> then: not totally dull and covers it pretty good. x = generic, test = test.
> Veritas does sound way nicer though ... At least for me funny names do
> stick better. For instance I dont seem to forget what the following names
> stand for, after making the association once:
> sublime == ui
> plasma  == kwidget
> dolpin  == kexplorer
> krita   == kpaint
> okteta  == khexedit
> marble  == kearth
> anyway, enough about a name! :)
> Manuel

Yep I also like some of those names, but we've got to consider 

On the other hand of course, I think "Veritas" sounds a lot better 
than "xTest". I'm fine with giving the test framework such a name, it just 
shouldn't be forced on the user. The tool-view should be called "Testing" 
imo, but maybe it could show a fancier name within it.

Greetings, David

More information about the KDevelop-devel mailing list