Andreas Pakulat apaku at gmx.de
Sun Feb 24 00:51:53 UTC 2008

On 24.02.08 01:34:13, David Nolden wrote:
> On Sunday 24 February 2008 01:10:50 Andreas Pakulat wrote:
> > Does this gain anything except fewer classes in the API? IMHO such API
> > changes should be discussed on the list instead of being decided simply
> > by you.
> >
> > The naming of the Declaration class(es) is now completely wrong as they
> > might also be definitions. No amount of apidox can help with such bad
> > namings.
> The thing is, that it was exactly the same way before. A declaration could 
> always be a definition. There was always isDefinition(..). There just was an 
> additional Definition class, and it wasn't clear when exactly to use 
> Definition and when Declaration with isDefinition.
> So essentially this is nothing more then removing a redundant class.

Yeah, still the naming is rather bad IMHO. So we should try to come up
with some better naming if possible. 

> Btw. are we planning to support any other language except C++ that 
> differentiates between Declaration and Definition?

Actually I can't think of any language that does this right now, in
particular I can't think of any "cool/hip" language that has separate
declarations. Anybody else?

If C++ is really the only case where declaration and definition can
differ maybe we should rename Declaration to Definition and move all the
declaration-related stuff into the c++ support?


You recoil from the crude; you tend naturally toward the exquisite.

More information about the KDevelop-devel mailing list