Namespacing in kdevelop/lib

Alexander Dymo dymo at
Wed Jul 19 14:41:53 UTC 2006

On Wednesday 19 July 2006 02:20, Matt Rogers wrote:
> I think it would be a good idea to namespace the classes in under the lib
Are there any concrete reasons to do this? 

> subdir and since i'm not so great at naming things, I'd like to get
> feedback on the following names that manyoso and I came up with on IRC.
> And the nominees are:
> KDev
It's already there, but without ::. No sense to change IMHO.

> KDevelop
Good enough if we go for namespaces.

> KDP (acronym for KDevelop Platform)
Too cryptic.

> No feedback after a few days means I'll just pick something, so please
> comment. :)
Hehe, it seems that as our svn commit rate is increasing, our mailinglist
responsiveness increases as well ;)

More information about the KDevelop-devel mailing list