Namespacing in kdevelop/lib

Adam Treat treat at
Wed Jul 19 00:07:02 UTC 2006

My vote is KDev ...
We already name all of the libs libkdev* and all of the files are currently 
kdev* (although this is _highly_ annoying) so why not the namespace too?


On Tuesday 18 July 2006 7:20 pm, Matt Rogers wrote:
> Hi,
> I think it would be a good idea to namespace the classes in under the lib
> subdir and since i'm not so great at naming things, I'd like to get
> feedback on the following names that manyoso and I came up with on IRC.
> And the nominees are:
> KDev
> KDevelop
> KDP (acronym for KDevelop Platform)
> No feedback after a few days means I'll just pick something, so please
> comment. :)
> --
> Matt
> _______________________________________________
> KDevelop-devel mailing list
> KDevelop-devel at

More information about the KDevelop-devel mailing list