KDevelop4 API questions
mattr at kde.org
Thu Aug 17 12:25:14 UTC 2006
On Thursday 17 August 2006 01:36, Andras Mantia wrote:
> On Thursday 17 August 2006 04:14, Adam Treat wrote:
> > Please don't. I know I need to document them, but they do have a
> > purpose...
> > projectDirectory == the dir where the current project file is
> > located.
> > projectsDirectory == the dir where the user holds all of his project
> > folders ... perhaps this can be renamed to better illustrate what it
> > is.
> Yes, this is what I imagined. To avoid confusion this is why I suggest
> renaming the methods:
> - projectDirectory => projectFileDirectory or globalFileDirectory, as in
> the API the project file is called global file
> - projectsDirectory => projectDirectory. I'm not a native speaker and I
> could imagine the name comes from "project's directory", but I find it
> The question about having a projectDirectory in KDevProject remains. If
> that is the same as projectsDirectory here, why do we need it in two
both of these functions are going away. projectsDirectory will be removed, and
projectDirectory will be removed in favor of KDevProject::projectDirectory.
> > Both of them are useful though, please don't remove.
> > > > KDevProjectController::openProject: the open dialog has hardcoded
> > > > information about KDevelop4 project files. This one should be
> > > > configurable in some way. Ideas are welcome.
> > All it has is the extension. We can easily make an API for setting
> > this extension.
> I like this better than subclassing. ;-)
More information about the KDevelop-devel