Refactor debuggerpart construction?

Vladimir Prus ghost at cs.msu.su
Mon Jul 4 11:47:05 UTC 2005


Hi,
at the moment, constructor of DebuggerPart class looks like this:

    variableWidget = new VariableWidget( 0, "variablewidget");
    variableWidget->setIcon(SmallIcon("math_brace"));
    variableWidget->setCaption(i18n("Variable Tree"));
    QWhatsThis::add
        (variableWidget, i18n("<b>Variable tree</b><p>"
                              "The variable tree allows you to see "
    .......

and the same pattern repeats for other widgets. I wonder if it would not be
better to move all of the above code into constructor of VariableWidget.
That way, VariableWidget will be much more self-contained.

Thoughs?

- Volodya
    





More information about the KDevelop-devel mailing list