- Missing "New Project" (CVS HEAD)

Frank Hasenklever thevoice at
Sun Jun 27 16:04:02 UTC 2004


I just wanted to begin with working on the CustomProjectPart.
However, I tried to compile and run the CVS HEAD branch of
kdevelop, before changing anything in the code.

It's compiling and running, but my kdevelop seems to be
missing some rudimental features. Have a look at this screenshot:
If everything was fine, there should appear a "New Project"
menu item on the Project menu.

On Freenode, #kdevelop, teatime told me, that I've got to
install the AppWizard Plugin for it to work. I looked for it
and found it:
voice at linuxism voice $ find /usr/kde/3.2/ -iname ''
/usr/kde/3.2/lib/kde3/ <-- exists!

So teatime told me to check, whether it was actually loaded
with kdevelop. We tried:
cat /proc/<kdevelop-pid>/maps | grep
Now, we were able to seize the problem, because grep did not
return anything. I made a copy of the cat /proc/<kdevelop>/maps
output for you:

Aware of the fact, that it really was a problem with this plugin,
we tried to find out, why it was not being loaded with kdevelop.
ldd /usr/kde/3.2/libs/kde3/ did not report any
problems, see:

I am at my wit's end, so I'm asking here. Maybe someone could
work this through with me, again. For the sake of completeness
I'm including the kdevelop debug output in this email
( ) and my

# autogenerated by env-update; make all changes to
# contents of /etc/env.d directory

I've got KDE 3.2.2 running ( kdelibs 3.2.2-r1 ) and I have only
got the cvs version of kdevelop installed (to be sure that there
aren't any conflicts with other libkdev* libraries).

Thanks so far,

More information about the KDevelop-devel mailing list