[Bug 82920] New: cvsroot isn't passed to cvs commit

Péntek Imre pentek_imre at mailbox.hu
Mon Jun 7 01:01:33 UTC 2004

------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.
           Summary: cvsroot isn't passed to cvs commit
           Product: kdevelop
           Version: 3.0.1
          Platform: unspecified
        OS/Version: Linux
            Status: UNCONFIRMED
          Severity: normal
          Priority: NOR
         Component: general
        AssignedTo: kdevelop-devel kdevelop org
        ReportedBy: pentek_imre mailbox hu

Version:           3.0.1 (using KDE KDE 3.2.1KDE 1.2)
Installed from:    Unlisted Binary PackageUnlisted Binary Package
Compiler:          gcc version 3.3.2 Configured with: /var/uhubuild/work/compile/configure --prefix=/usr --infodir=/usr/share/info --mandir=/usr/share/man --enable-languages=c,c++,objc,java,f77,pascal --enable-shared --with-gnu-as --with-gnu-ld --with-system-zlib --host=i386-pc-linux-gnu
OS:                Linux

I tried to create a c++ console project with cvs. The cvs was initialized (as I see) correctly, but then when I tried to commit using Tools -> Version control -> CVS -> Commit this was appeared in the cvs log:
cd '/tmp/probacvs' && cvs -f commit -m 'boo ;)  ' 'src/probacvs.cpp'
cvs commit: in directory .:
cvs commit: ignoring CVS/Root because it does not contain an absolute pathname.
cvs commit: No CVSROOT specified! Please use the `-d' option
cvs [commit aborted]: or set then CVSROOT environment variable.
*** Exited with status: 1 ***
And as I said it succeeded to initialize CVS at the beginning, when created the project I gave an absolute path as a CVS root.

More information about the KDevelop-devel mailing list