Compiling issue on KDE 3.0.x system

Iztok Kobal iztok.kobal at
Thu Sep 18 11:11:02 UTC 2003

Andrea Rizzi wrote:

>Hi all,
>I tried to compile gideon on a KDE 3.0.x (QT 3.0) system (the one used at 
>CERN)  and I have found some easy to fix compiling problems.
>I used 15/09/2003 snapshots of gideon.

>1)QVariant::isNull()  is used  (do not exists in QT 3.0), a ==0 seems to work.
>and here:lib/widgets/propeditor/psymbolcombo.cpp
>if (!value.isNull())
I used the canCast method instead isNull. First appearance is casted to 
QVariant::String and second one to QVariant::Int. Alex should tell if 
replacement wil do its job or not.

>2)QString::replace(QString, QString) seems to be private in QT 3.0 using
>  replace(QRegExp(string1), string2) worked.
Use QString::replace(QRegExp(original argument), original_2nd_argument) 
instead, that is, only wrap the first argument with the QRegExp(). This 
is to be done in only one place.

>plugins/pcsimporter/customimporter gives errors: 
>settingsdialog.cpp:40: use of `KEditListBox' is ambiguous
>/usr/include/kde/keditlistbox.h:39:   first declared as `class
>KEditListBox' here
>../../../lib/compat/kdeveditlistbox.h:37:   also declared as `class 
>KDevCompat::KEditListBox' here
>settingsdialog.cpp:40: `KEditListBox' denotes an ambiguous type
Good to hear from Dymo that it was fixed.

>4) doc/kdevelop/index.docbook do not compile 
ln -s $KDEDIR/share/apps/ksgmltools2/customization/dtd 

Good Luck

For Amilcar and Alex - I will send patch concerning the first two 
problems as soon as possible if you do not do it before me.

Iztok Kobal

More information about the KDevelop-devel mailing list