Missing plugins

Robert Jonsson robert.jonsson at dataductus.se
Sun Sep 14 19:22:05 UTC 2003

Hello again,

Tuesday 09 September 2003 19:40 skrev Harald Fernengel:
> Hi,
> On Saturday 06 September 2003 23:52, Robert Jonsson wrote:
> > I just built a new version of gideon, was a few weeks since last.
> >
> > The strangest bug just bit me.
> >
> > I've got an available c++ codebase that I try to import but gideon just
> > puts up a dialog box with a text 'No project management plugin
> > KDevAutoProject' with c++ autoproject and, KDevCustomProject with
> > c++custom.
> >
> > I checked and in /usr/lib/kde3 i got some files such as
> > libkdevautoproject.so.
> >
> > Any ideas, my setup or a bug?
> KDevelop will refuse to load plugins with the wrong version number, version
> 1 was introduced during the KDE conference, so you probably need a clean
> build/install, preferably into your KDE directory.

I have now tried to reinstall kdevelop several times (updating from CVS) with 
about the same success, (nil).

It's the same problem however I try, import a project, start a new project, 
they all fail with an error that there isn't any plugin (see above).

I tried to remove (by hand) potentially errenous plugins, but I didn't find 
many, the ones I found had nothing to do with Project.

Is there anything else that has changed lately(last month) wrt to plugins or 
project management? (probably too much to list ;-)

If the problem was as Harald suggested, that there was a plugin with wrong 
revision, does Gideon just silently skip that one, or should it produce an 
error somehow? Is it possible to make it produce an error?

The problems persist on my box at home, I can live without it for the time 
being so it's no biggie, at work there are no problems.
It would be nice though to figure out why this happens.


More information about the KDevelop-devel mailing list