[Bug 64107] KDevelop 3.0.0a6 configure/compile problem: python header detection

Nicolai Haehnle prefect_ at gmx.net
Sat Sep 13 16:07:04 UTC 2003

------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

------- Additional Comments From prefect_ at gmx.net  2003-09-13 16:06 -------
Subject: Re:  KDevelop 3.0.0a6 configure/compile problem: python header detection

On Saturday 13 September 2003 14:46, you wrote:
> ------- You are receiving this mail because: -------
> You reported the bug, or are watching the reporter.
> http://bugs.kde.org/show_bug.cgi?id=64107
> ------- Additional Comments From a.lucas at tu-bs.de  2003-09-13 14:46
> -------
> > It's a bug in the configure script that comes with the KDevelop 3.0.0a6
> > distribution.
> Guess what we are not responsible for the distribuition.

Okay, I'm CC'ing Stephan Kulow, who is listed as release coordinator for KDE 

> But the solution should be to execute:
> make -f Makefile.cvs
> This will recreate a new tailiored configure script for your system.

Isn't the point of configure scripts that they tailor the build towards my 
system, i.e. they are (or should be) completely system independent?

> This script will replace the broken one you got from your distribuitor.

I'd just like to point out again, that the "distributor" in this case is the 
KDE or KDevelop project, or maybe the release coordinator if you want to be 
more precise. For somebody who is not "inside" those projects, it's a bit 
difficult to know how things are dealt with.
(Besides, does the release coordinator actually work on the configure 
scripts apart from running Makefile.cvs?)

> > That's fine with me, but if you want it to be that way, you have to say
> > so somewhere! There is no indication whatsoever on
> > http://bugs.kde.org/, and there is no indication whatsoever on
> > http://www.kdevelop.org/
> Thanks for pointing that out, I've fixed it.
> > automake 1.4-p6
> I think that here lies your problem. To use automake < 1.6.1 you need to
> use the trick described at:
> http://www.kdevelop.org/index.html?filename=requirements.html
> > And yes, I *am* talking about the configure script that comes with the
> > KDevelop 3.0.0a6 tarball.
> >
> > And yes, maybe this bug is triggered by something external, like
> > autoconf or automake. But I've said it in the bug report, and I'll say
> > it again here: The part of the configure script that is supposed to
> > detect Python did detect Python correctly! It reported to stdout that
> > no Python headers or libraries are installed, and it did find the
> > executable that *was* installed. It just didn't stop the compilation as
> > it should have.
> Please test the solutions that I've provided and let me know if it solved
> your problem.
> You can reply to me using :
> http://bugs.kde.org/show_bug.cgi?id=64107

Please understand that this bug is not a problem for me, and it has never 
been one. Working around this bug is a simple matter of installing the 
python-dev package. I'm just posting here in order to help improve the 
overall "KDevelop experience", if you will.

It doesn't have anything to do with the version of automake. In fact, I get 
the exact same results when automake is not installed at all. This is not 
surprising; after all, configure scripts are supposed to work without 
automake, since most non-developers don't have an automake installation.

I investigated a little further in this, even though I have zero clue how 
creating configure scripts works. There's a script KDEV_CHECK_SCRIPTING in 
kdevelop.m4.in. This in turn calls a script KDE_CHECK_PYTHON. Apparently, 
this then sets a #define HAVE_PYTHON if the development headers are 
The configure script correctly #undef's the HAVE_PYTHON define. So that part 
of the configure process does seem to work correctly.

The only thing that's missing is that the KDEV_CHECK_SCRIPTING script 
doesn't complain about the fact that HAVE_PYTHON is not set when 
- --enable-scripting is used. However, I have no idea how to make it do that 
- - probably some combination of if-clause and AC_MSG_ERROR or something.

Version: GnuPG v1.2.3 (GNU/Linux)


More information about the KDevelop-devel mailing list