Bug#33696: marked as done (crash on startup / loading a project) by "F at lk Brettschneider" <gigafalk at yahoo.com>

Stephan Kulow owner at bugs.kde.org
Wed Jan 23 10:13:19 UTC 2002

Your message with subj: unprecise useless report - seems to be fixed

Do You Yahoo!?
Get your free @yahoo.com address at http://mail.yahoo.com

has caused the attached bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I'm
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Stephan Kulow
(administrator, KDE bugs database)

Received: (at submit) by bugs.kde.org; 14 Oct 2001 22:22:09 +0000
Received: (qmail 6010 invoked by uid 33); 14 Oct 2001 22:22:09 -0000
Date: 14 Oct 2001 22:22:09 -0000
Message-ID: <20011014222209.6009.qmail at master.kde.org>
To: submit at bugs.kde.org
Subject: crash on startup / loading a project
From: dquintas at telecable.es

Package:           kdevelop
Version:           KDE 2.2.1 
Severity:          normal
Installed from:    Compiled From Sources
Compiler:          gcc 2.96
OS:                Linux
OS/Compiler notes: Not Specified

Kdevelop crashes on startup (sometimes) and always when I try to open an existing project of file. It doesn't happens the first time I run kdevelop, but the second and so times, it crashes. If I delete my ~/.kde/shared/apps/kdevelop and kdeveloprc it runs again, but only for the first time. It happens both in Kdevelop 2.0.1 and 2.2.0beta (this one compiled from sources).

This is what i get from KCrash:

0x412021d9 in wait4 () from /lib/libc.so.6
#0  0x412021d9 in wait4 () from /lib/libc.so.6
#1  0x4127fef8 in __check_rhosts_file () from /lib/libc.so.6
#2  0x4098a2ae in KCrash::defaultCrashHandler () from /usr/lib/libkdecore.so.3

#3  0x40ab7847 in _IO_2_1_stderr_ () from /usr/lib/libstdc++-libc6.2-2.so.3

and this is what shows the terminal where i run kdevelop from:

QToolBar::QToolBar main window cannot be 0.
QObject::connect: Cannot connect CEditWidget::editBreakpoint(const QString&,int) to (null)::slotEditBreakpoint(const QString&,int)
QObject::connect: Cannot connect CEditWidget::toggleBPEnabled(const QString&,int) to (null)::slotToggleBPEnabled(const QString&,int)
QObject::connect: Cannot connect CEditWidget::toggleBreakpoint(const QString&,int) to (null)::slotToggleStdBreakpoint(const QString&,int)
QObject::connect: Cannot connect CEditWidget::clearAllBreakpoints() to (null)::slotClearAllBreakpoints()
KCrash: crashing.... crashRecursionCounter = 2
KCrash: Application Name = kdevelop path = <unknown> pid = 32177

Altough I've seen that there are similar bug reports, it doesnt appear to be fixed and there are differences in the KCrash backtrace.

This is a Mandrake 8.1
gcc 2.96
glibc 2.4.4
kernel 2.4.10 w/ xfs support

(Submitted via bugs.kde.org)
(Called from KBugReport dialog. Fields Application, KDE Version, OS, Compiler manually changed)

More information about the KDevelop-devel mailing list