Bug#39692: marked as done (Debugging crashes application. Normal execution works.) by John Firebaugh <jfirebaugh at kde.org>

Stephan Kulow owner at bugs.kde.org
Sat Aug 31 07:49:54 UTC 2002

Your message with subj: Debugging crashes application. Normal execution works.

Thank you for your bug report.
The bug that your reported no longer applies to the latest development (CVS) 
version of KDE. This is most probably because the bug has been fixed, the 
application has been substantially modified, or the application no longer 
exists. The bug report will be closed.

has caused the attached bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I'm
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Stephan Kulow
(administrator, KDE bugs database)

(Complete bug history is available at http://bugs.kde.org/db/39/39692.html)

Received: (at submit) by bugs.kde.org; 23 Mar 2002 10:52:23 +0000
Received: (qmail 25498 invoked by uid 33); 23 Mar 2002 10:52:23 -0000
Date: 23 Mar 2002 10:52:23 -0000
Message-ID: <20020323105223.25497.qmail at mail.kde.org>
To: submit at bugs.kde.org
Subject: Debugging crashes application. Normal execution works.
From: andreas at pietzowski.de
X-KDE-Received: -

Package:           kdevelop
Version:           2.1 (from KDE-RC3) (using KDE 2.9.2 )
Severity:          normal
Installed from:    Compiled From Sources
Compiler:          gcc version 2.95.3
OS:                Linux
OS/Compiler notes: I compiled qt-3.0.2 with -thread and -qt-sql-mysql


I have an application (built with KDevelop from KDE-2.2.2). This app uses the myscql-client-libs and -API. The app worked fine under Qt2. No I wanted to switch to Qt3 so I compiled qt-3.0.2 with SQL-Support.

If I compile my application now in KDevelop it runs normal but if I want to debug it in KDevelop then my application crashes or couldn't connect to the MySQL-DB.

I tried it without Qt-SQL-Support (using th mysql-client-API) and the app works quite fine but the same thing: When I start debugging it runs until mysql_init(NULL) is called. But this init-function works quite fine under Qt2 and KDevelop from KDE-2.2.2.

I guess this has something to do with threading (which I have to turn on because without threading KDevelop wouldn't do any new project ;-) because the only difference I can see in g++ parameters is -DQT_THREAD_SUPPORT

Can you imagine whats the bug? Is it KDevelop or something I should write to trolltech?

I tried KDevelop 2.1 under KDE3-rc3 and under KDE-2.2.2 with the same behavior.


(Submitted via bugs.kde.org)

More information about the KDevelop-devel mailing list