emacs part and QXEmbed

Marcus Gruendler runner at tamalin.de
Sat Sep 15 15:20:49 UTC 2001

Hi there,

Two weeks ago, I posted a patch for gideon on the kdevelop list, that enabled 
the use of emacs as the editor for gideon. This emacs KPart simply started 
emacs and controlled it via the gnuclient program.

But there are some things I didn't like about it. First of all, emacs wasn't 
embedded into gideon. So, whenever I edit a text in emacs, emacs has to get 
the focus. When I want to use some gideon functionality, I must switch back 
to gideon, which hides the emacs window.

So I decided to embed emacs into a Qt widget. Ralf pointed me to the QXEmbed 
class which does this job. While this works fine for a plain KDE application, 
I cannot make it work as a gideon editor-part. 

Whenever a document is opened, emacs starts up and when it gets embedded into 
the qxembed widget it disappears and no emacs is visible anymore. Why? I 
replaced the qxembed widget by a QMultiLineEdit widget and left all other 
code the same. Then it worked.

So my questions are:

* Has anyone experience with the QXEmbed class? 
* Is this class buggy/unfinished?
* Has anyone tried to embed an X application into a widget yet?

Thanks for any help, Marcus

to unsubscribe from this list send an email to kdevelop-devel-request at kdevelop.org with the following body:
unsubscribe »your-email-address«

More information about the KDevelop-devel mailing list