Remote cvs access via SSH in KDevelop 1.4

Simon Hausmann hausmann at
Fri Sep 14 07:37:50 UTC 2001

On Wed, Sep 12, 2001 at 06:38:07AM -0700, cihan esen wrote:
> Thanks for help, but i still couldn't solve my
> problem.
> First of all, my account on the server was already
> configured to allow connection based on my ssh key.I
> can do anything on cvs via ssh as long as i provide my
> username and password each time i try to do something
> on cvs.
> I followed your advices. When i tried the command 
> eval ssh-agent

Noo, it's eval `ssh-agent` 
> linux printed 3 lines exactly as this
> SSH_AUTH_SOCK=/tmp/ssh-XXXTMP3R/agent.1203; export
> echo Agent pid 1204;
> then i did the command
> ssh-add
> linux said
> Could not open a connection to your authentication
> agent
> then i used the command
> printenv
> and i saw that, the two environment variables that
> "eval ssh-agent" command tried to set, was not set. I
> set them manually via "export" as "eval ssh-agent"
> command printed.After this when i commit "ssh-add"
> command, it printed a line like this
> Identity added: /home/myusername/.ssh/identity
> (myusername at mycomputer)
> but i still got the same message on KDEvelop as
> before(I'd given the message on my previous e-mail).It
> seems as if KDevevelop still couldn't make the server
> to resolve my username and password. For instance, i
> thought that when i open an ssh-agent whenever i try
> to make an ssh connection on console to the server it
> won't ask me username and password but it did.

Are you sure your default identity is the one that is
listed in authorized_keys on the server? 

Does the following sequence of commands work?

eval `ssh-agent`
<type your password here>
ssh user at remotehost

You should now get a login shell. If that works try
starting kdevelop from that very shell.


to unsubscribe from this list send an email to kdevelop-devel-request at with the following body:
unsubscribe »your-email-address«

More information about the KDevelop-devel mailing list