- Directory variables naming issue - patch

Lorenzo Delana ldelana at
Wed Jun 27 13:34:55 UTC 2001

Patch file:	automake_dir_var_name.patch
Affected files:	kdevelop/kdevelop/cproject.{h,cpp}
CVS Sync:	Jun 27 14:33
Branch:		KDEVELOP_1_4
Generated by:	Lorenzo Delana <ldelana at>
Generated with:	patch -u --new-file <cvs_file> <patched_file>
Short Descr.:	apply nameing convention for automake directory variables
Long Descr.:	(from automake manual)
/** How derived variables are named (...from GNU automake manual)
	 * Sometimes a Makefile variable name is derived from some text the user
	 * supplies. For instance program names are rewritten into Makefile macro
	 * names. Automake canonicalizes this text, so that it does not have to
	 * follow Makefile variable naming rules. All characters in the name except
	 * for letters, numbers, and the underscore are turned into underscores when
	 * making macro references. E.g., if your program is named sniff-glue, the
	 * derived variable name would be sniff_glue_SOURCES, not 
sniff-glue_SOURCES. */
Backward Compatibility:	all (y have to touch bugged to let 
KDevelop recreate it)
Test rule:	create a project, add a folder with name "" and create 
into it a class "test", then try....

to apply this patch, from outside source tree of kdevelop:

	patch -p0 < automake_dir_var_name.patch

Note: CVS Sync in the report, refers to my CVS snapshot that I have used to 
make the patch.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: automake_dir_var_name.patch
Type: text/x-c++
Size: 2695 bytes
Desc: not available
URL: <>

More information about the KDevelop-devel mailing list