apply patch

W. Tasin tasin at fhm.edu
Sun Jul 8 22:52:49 UTC 2001


Hi again,

stooooop ... please don't do this in this way...

Lorenzo Delana wrote:

>On Sunday 08 July 2001 22:12, you wrote:
>
>>Hi Falk, Salve Lore,
>>
>>is there a reason not to use your patch for the shared lib section?
>>
>>Ciao
>>
>
>In fact, y have reason...
>someone, possibly Falk, can apply patch manually to shared lib section simply 
>using this implemented prototype:
>
>QString CProject::canonicalDirName(QString dir_name)
>
>Note: possibly, Falk, y can add the "static" to that function, changeing in 
>cproject.h with:
>

first at all don't change this to a static method unless there is no 
reason for it...
as far as I can see canonicalDirName() is only used inside CProject 
methods, right?

So don't compromise the OOP...
use static only if another method outside an CProject object would use it...

I think a better name would be also canonicalLibName or sth. similar, 
but this is no functional objection....

IMHO the function should also pass a const QString & instead of a new 
QString copy...
result:
QString CProject::canonicalLibName(const QString &)


>
>static QString CProject::canonicalDirName(QString dir_name);
>
>so everywhere CProject::canonicalDirName(str) can be called.
>
>Patch (manual) ------------------------------
>file:cproject.cpp 894 (INSERT FOLLOW)
>          // canonicalize libRootName
>          libRootName = canonicalDirName(libRootName);
>----------------------------------
>

sorry, another thing I cannot agree.
Don't do this only at this point.
As far as I can see from the sources the canonical name should only 
apply for macro labels containing the name,  like in

lib<canonical_name>_la_LIBADD=
lib<canonical_name>_la_SOURCES=

but not in

lib_LTLIBRARIES = lib<real name>.la

--------

e.g. for library test-one it should look like:

lib_LTLIBRARIES=libtest-one.la
libtest_one_la_LIBADD= -lm
libtest_one_la_SOURCES= one.cpp two.cpp

--------

Applying your manual patch would cause:
lib_LTLIBRARIES=libtest_one.la


correct me if I'm wrong!!


Ciao

Walter

>
>thnx
>bye Lore
>

PS: Unfortunately I cannot apply the patch because I cannot compile 
KDevelop, here's the reason
(either with or without -DUSE_KDE_2_1_1):

c++ -DHAVE_CONFIG_H -I. -I. -I../../../.. -I/opt/kde2/include 
-I/usr/lib/qt2/include -I/usr/X11R6/include 
-I../../../../kdevelop/widgets/qextmdi/include 
-I../../../../kdevelop/widgets/qextmdi/res -O2 -fno-exceptions 
-fno-check-new -Wp,-MD,.deps/qextmdichildarea.pp -c 
qextmdichildarea.cpp  -fPIC -DPIC -o .libs/qextmdichildarea.o
qextmdichildarea.cpp: In method `void 
QextMdiChildArea::destroyChild(QextMdiChildFrm *, bool = TRUE)':
qextmdichildarea.cpp:115: implicit declaration of function `int 
noMaximizedChildFrmLeft(...)'
In file included from qextmdichildarea.cpp:616:
qextmdichildarea.moc: In function `static class QMetaObject * 
QextMdiChildArea::staticMetaObject()':
qextmdichildarea.moc:134: `noMaximizedChildFrmLeft' is not a member of 
type `QextMdiChildArea'
qextmdichildarea.moc:136: initialization to `void 
(QextMdiChildArea::*)(bool)' from `void (QextMdiChildArea::*)()'
qextmdichildarea.moc:136: conversion to `void 
(QextMdiChildArea::*)(bool)' from
`void (QextMdiChildArea::*)()'
In file included from qextmdichildarea.cpp:616:
qextmdichildarea.moc: At top level:
qextmdichildarea.moc:175: no `void 
QextMdiChildArea::noMaximizedChildFrmLeft(QextMdiChildFrm *)' member 
function declared in class `QextMdiChildArea'
qextmdichildarea.moc:214: prototype for `void 
QextMdiChildArea::nowMaximized(bool)' does not match any in class 
`QextMdiChildArea'
/usr/lib/qt2/include/qextmdichildarea.h:234: candidate is: void 
QextMdiChildArea::nowMaximized()
make[5]: *** [qextmdichildarea.lo] Error 1
make[5]: Leaving directory 
`/home/tasin/CVS-KDE/kdevelop/kdevelop/widgets/qextmdi/src'
make[4]: *** [all-recursive] Error 1
make[4]: Leaving directory 
`/home/tasin/CVS-KDE/kdevelop/kdevelop/widgets/qextmdi'
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory `/home/tasin/CVS-KDE/kdevelop/kdevelop/widgets'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/home/tasin/CVS-KDE/kdevelop/kdevelop'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/tasin/CVS-KDE/kdevelop'
make: *** [all-recursive-am] Error 2



-- 
The KDevelop project: tasin at kdevelop.de [www.kdevelop.org]
--
oohhh sveglia.... il mondo e' ammalato, ma x colpa di chi.........
(Zucchero)
:-------W. Tasin, FB 04,FHM-------------------PGP-KeyID:0x7961A645----------:
<Key-Fingerprint: 1610 835F 0080 32F4 6140  6CF7 A7D0 44CD 7961A645>





-
to unsubscribe from this list send an email to kdevelop-devel-request at kdevelop.org with the following body:
unsubscribe »your-email-address«



More information about the KDevelop-devel mailing list