beautifying code
Falk Brettschneider
gigafalk at yahoo.com
Tue Sep 19 23:54:56 UTC 2000
Hi KDevelop-team,
I suggest we all should use nearly the same coding style in KDevelop
because it's quite ugly to see different styles in one file.
I would prefer a few rules:
- prefix "m_" for class attributes
- prefix "p" for pointers
- prefix "m_p" for class attributes which are pointers
- upper case letters for each single word in a compound word: e.g.
KDevViewHandler instead of Kdevviewhandler.
- tab space = 3
- tabs replaced by spaces
- prefix "b" for boolean variables
- no prefix "get" at the beginning of a get function.
Please, tell me your opinions. I just want to find a consense. :-)
Cheers,
F at lk
__________________________________________________
Do You Yahoo!?
Talk to your friends online with Yahoo! Messenger.
http://im.yahoo.com
More information about the KDevelop-devel
mailing list