Bug#2267: Class parser seems not to recognize namespaces

Guido Tack guido at odiug.de
Tue Nov 9 22:53:24 UTC 1999

Package: kdevelop
Version: 1.0beta4.1
Severity: normal

Bugreport ID : 23:48,09.11.99

Originator	: Guido Tack
E-Mail		: guido at odiug.de

Subject : Class parser seems not to recognize namespaces

Error Class	: software bug
Error Location	: class tree
Priority	: medium
Bug Description ---------------------------

I tried to load an old project into the new KDevelop, and the classparser
stays at "7%", I have to kill KDevelop with kill .
Then I noticed that when I tried to only load those source files which contain
methods in a namespace, the classparser hangs, too.
After putting everything in the default namespace by commenting out "namespace ... {"
everything works fine now.

How to repeat the error -------------------

It seems it always crashes.

Bugfix or Workaround ----------------------

Don't know.

System Information ------------------------

KDevelop version	: 1.0beta4.1
KDE version		: 1.1.2
QT version		: 1.44
OS/Distribution		: SuSE 6.2
Compiler		: gcc version egcs-2.91.66 19990314/Linux (egcs-1.1.2 release)

misc :

More information about the KDevelop-devel mailing list