[Akonadi] [Bug 440717] New: akonadi incompatible with MariaDB 10.6.4?

Ricardo J. Barberis bugzilla_noreply at kde.org
Sun Aug 8 01:31:59 BST 2021


            Bug ID: 440717
           Summary: akonadi incompatible with MariaDB 10.6.4?
           Product: Akonadi
           Version: unspecified
          Platform: Slackware Packages
                OS: Linux
            Status: REPORTED
          Severity: normal
          Priority: NOR
         Component: server
          Assignee: kdepim-bugs at kde.org
          Reporter: ricardo.barberis at gmail.com
  Target Milestone: ---


Today I Slackware upgraded MariaDB from 10.5.11 to 10.6.4 and after a reboot
akonadi started throwing errors.

I started mysql with `/usr/libexec/mysqld
--pid-file=/run/user/1000/akonadi/mysql.pid &`

Then unsuccesfully tried a `mysql_upgrade
--socket=/run/user/1000/akonadi/mysql.socket` which seemed to run but in the
mysql log I see:

error: 'Access denied for user 'root'@'localhost''

I also can't connect with `mysql --socket=/run/user/1000/akonadi/mysql.socket`,
same "Access denied" error.

I killed the mysql process and started it again, ran mysql_upgrade with the
same exact result.

I made a backup of /home/myuser/.local/share/akonadi and tried downgrading,
doing a dump and restore to no avail, I still see logged:

DB error:  "Incorrect datetime value: '2021-08-07T23:34:22Z' for column
`akonadi`.`pimitemtable`.`datetime` at row 1"

My biggest problem is that now kmail doesn't work anymore, I tried an empty
akonadi database and I may have broken it even more :/

1. Upgrade MariaDB 10.5.x to 10.6.4
2. Start/restart akonadi (e.g. akonadictl start/restart)
3. Check the logs


In akonadi's log:

org.kde.pim.akonadiserver: DATABASE ERROR:
org.kde.pim.akonadiserver:   Error code: "1292"
org.kde.pim.akonadiserver:   DB error:  "Incorrect datetime value:
'2021-08-07T23:34:22Z' for column `akonadi`.`pimitemtable`.`datetime` at row 1"
org.kde.pim.akonadiserver:   Error text: "Incorrect datetime value:
'2021-08-07T23:34:22Z' for column `akonadi`.`pimitemtable`.`datetime` at row 1
QMYSQL: No es posible ejecutar la consulta"  <-- "Unable to execute query"


akonadi working with MariaDB 10.6


Operating System: Slackware 15.0 (beta/current)
KDE Plasma Version: 5.22.4
KDE Frameworks Version: 5.84.0
Qt Version: 5.15.2
Kernel Version: 5.13.8 (64-bit)
Graphics Platform: X11
Processors: 8 × Intel® Core™ i5-1035G1 CPU @ 1.00GHz
Memory: 15.2 GiB of RAM
Graphics Processor: Mesa Intel® UHD Graphics


You are receiving this mail because:
You are the assignee for the bug.

More information about the Kdepim-bugs mailing list