[Akonadi] [Bug 343114] gets stuck on one request that times out, kmail and akonadiconsole do not display any mail payloads anymore, stuck waiting

David C. Bryant bugzilla_noreply at kde.org
Mon Aug 5 15:06:43 BST 2019


--- Comment #8 from David C. Bryant <davidbryant at gvtc.com> ---
Well, my version of PIM (Akonadi et al.) is 5.7.3, and that's not on the list,
so that's why I said "unspecified" ... there wasn't any way to say "other" and
fill in the blank, that I could see.

My issue isn't at startup time. KMail just freezes up from time to time,
apparently at random. I download all my e-mail using POP, so my set of folders
is pretty big and elaborate -- about 20,000 files and 1.6GB, according to
Dolphin. I've been using KMail since 2003.

I don't have enough room to run more than one version of Linux on my current
box. And it takes a lot of work to install a new release.So thanks for the
suggestion about 15.1, but I'm not likely to undertake that endeavor right

I have already tried stopping akonadi and restarting it. I don't think there
are any issues with KMail when it first starts -- just a minute -- I'll go
check. I do get a couple of warning messages.

[0805/084258.513261:WARNING:stack_trace_posix.cc(648)] Failed to open file:
/home/david/#2753352 (deleted)
  Error: No such file or directory
1 : "Uncaught ReferenceError: qt is not defined"
1 : "Uncaught ReferenceError: qt is not defined"

The first one makes some sense to me ... after KMail froze up the last time,
there were about 100 spurious objects ("no RID") and 75 spurious files
("unreferenced external files") when I ran "akonadictl fsck". Akonadi wouldn't
get rid of all of them on its own, so I resorted to brute force (I got this
trick from somebody named Karl (Langenfeldt?) in the openSuSE forums.)

~: find .local/share/akonadi/file_db_data/ -type f|xargs rm

As I recall, that erased about 20 unreferenced external files. So the one file
KMail is squawking about may be one of those.

The other messages, about "qt", make no sense to me, at all. Thanks!

PS I just opened this bug report because I haven't had this problem with KMail
until very recently. It's not a real big deal as far as I'm concerned. It's
just an annoyance -- when it stops working, I have to shut KMail down, than log
out of Plasma and log back in again. That takes maybe 2 or 3 minutes. A
nuisance, but not the end of the world.  :)

(In reply to Martin Steigerwald from comment #7)
> Dear David, thanks for adding your update to the bug report. However, if you
> change the version please also really set a new version, instead of setting
> 'unspecified'. Do 'akonadictl --version' and specify the version you see in
> the bug report. If the version is not in the selection, please select the
> closest one and put the output of the command in a comment. Please do not
> expect upstream developers to know or dig out what version OpenSUSE LEAP
> 15.0 would contain.
> Also preferably use OpenSUSE LEAP 15.1 to test with the newest version
> available.
> Additionally for me "akonadictl stop" and "akonadictl start" worked in order
> to bring Akonadi back into a working state. So your issue may even be
> something completely different. It would be beneficial to at least gather
> some console output to see whether you are really having the same issue.
> Especially whether you see the same:
> request for item 1669405 "902" failed: "Unable to retrieve item from
> resource: Did not receive a reply. Possible causes include: the remote
> application did not send a reply, the message bus security policy blocked
> the reply, the reply timeout expired, or the network connection was broken." 
> kind of messages. For that to see start kmail from a terminal.

You are receiving this mail because:
You are on the CC list for the bug.
You are the assignee for the bug.

More information about the Kdepim-bugs mailing list