[kmail2] [Bug 344163] New: "Unable to fetch item from backend (collection 8260) : Unable to retrieve item from resource"

piedro piedro.kulman at googlemail.com
Sat Feb 14 15:19:03 GMT 2015


            Bug ID: 344163
           Summary: "Unable to fetch item from backend (collection 8260) :
                    Unable to retrieve item from resource"
           Product: kmail2
           Version: 4.14.4
          Platform: Archlinux Packages
                OS: Linux
            Status: UNCONFIRMED
          Severity: normal
          Priority: NOR
         Component: general
          Assignee: kdepim-bugs at kde.org
          Reporter: piedro.kulman at googlemail.com

After importing a whole maildir from a NAS archive (created via rsync from
another computer) I can open and work with many mails but when I try to open
some mails, try to move or delete the folder of that mail or otherwise
manipulate it I get the following: 

'Unable to fetch item from backend (collection 8260) : Unable to retrieve item
from resource' 

Trying to do anything with the folder containing the affected mail results in 

'local folder: error reading folder, maildir "" is invalid' 

The other mails in the folder open fine an can be moved or deleted. 

This would be a minor problem if I could see all the affected mails, but it's
guesswork which mails are the ones that create "invalid entries"... but as is
it is a major problem because there are folders with over 2000 mails that give
me this error ... 

I have no idea how to clean up, resolve or workaround this issue. 

The best hints I find are: 
"reindex the folder by clicking "reindex this folder" in the folder tab
Well, there is no more option to that since there is no more nepomuk. 

- first of all this should not happen 
- second if there is an "invalid entry" with some mails this must not make the
whole folder unusable 
- third the error message should be clear and give some clue about which mails 
and what to do
- and finally: if something about an imported mail is "invalid" in a way that
kmail can't handle it this mail should not be imported at all

Even in the KDE forums nobody how to clean this up after importing a few
thousand mails. 
(these mails are all kmail mails from an rsynced local-mail directory on a
BTW: I tried reimporting folder by folder but that had the same result. 

Reproducible: Always

You are receiving this mail because:
You are the assignee for the bug.

More information about the Kdepim-bugs mailing list