[Bug 285809] New: Kmail dead slow while stuck synchronizing two folders in KMail maildirs

Richard Van Den Boom richard.vdboom at gmail.com
Sat Nov 5 11:37:56 UTC 2011


https://bugs.kde.org/show_bug.cgi?id=285809

           Summary: Kmail dead slow while stuck synchronizing two folders
                    in KMail maildirs
           Product: kmail2
           Version: 4.7
          Platform: Slackware Packages
        OS/Version: Linux
            Status: UNCONFIRMED
          Severity: normal
          Priority: NOR
         Component: folders
        AssignedTo: kdepim-bugs at kde.org
        ReportedBy: richard.vdboom at gmail.com


Version:           4.7 (using KDE 4.7.3) 
OS:                Linux

I just upgraded my slackware system with the latest packages of KDE 4.7.3 and
akonadi 1.6.2 from Alien Bob, which are usually very reliable.
KMail and Kontact worked roughly well with the 4.7.2 packages, provided I
disabled Nepomuk which brought Kontact to a crawl.
After the upgrade, Kontact is stuck when starting at 0% synchronizing 2
subdirs, one with about 7000 mails and the other with about 3500, both being
the target to new mails for two different accounts. The two folders on which
Kontact gets stuck are always the same, called "Nouveaux" which means "New" in
french.

I created initially three maildirs akonadi ressources, as Kmail maildirs to be
able to choose their name, as I manage several different POP account and I like
to keep my mails from different accounts if different places. I also created a
fourth KMail maildir but for some reason it never showed up in Kmail, I'll file
another bug report when I'll have time.

The issue is that I cannot see any mail anymore as long as the two folders are
not synchronized. I can read new mails and the ones in small folders, that
probably were synchronized before Kontact gets to my two "Nouveaux" maildirs.

I can still use Kontact, opening menus and config.
Curiously, Kmail in the same situation does not show the maildir being
synchronized but is still very slow to display some mails. I get the following
errors in the console :


"/usr/bin/kmail(5244)" Soprano: "QLocalSocket::connectToServer: Invalid name"
"/usr/bin/kmail(5244)" Soprano: "org.freedesktop.DBus.Error.ServiceUnknown -
The name org.kde.nepomuk.services.nepomukstorage was not provided by any
.service files"
"/usr/bin/kmail(5244)" Soprano: "Unsupported operation (2)": "Invalid model"
"/usr/bin/kmail(5244)" Soprano: "org.freedesktop.DBus.Error.ServiceUnknown -
The name org.kde.nepomuk.services.nepomukstorage was not provided by any
.service files"
"/usr/bin/kmail(5244)" Soprano: "Unsupported operation (2)": "Invalid model"
"/usr/bin/kmail(5244)" Soprano: "Unsupported operation (2)": "Invalid model"
"/usr/bin/kmail(5244)" Soprano: "Invalid iterator."
kmail2(5244): Error while fetching items.  103 "Erreur inconnue. (Impossible de
lister la collection racine.)" 
kmail2(5244): Error while fetching items.  103 "Erreur inconnue. (Impossible de
lister la collection racine.)" 
kmail2(5244): Error while fetching items.  103 "Erreur inconnue. (Impossible de
lister la collection racine.)" 
kmail2(5244): Error while fetching items.  103 "Erreur inconnue. (Impossible de
lister la collection racine.)" 
kmail2(5244): Error while fetching items.  103 "Erreur inconnue. (Impossible de
lister la collection racine.)" 
kmail2(5244): Error while fetching items.  103 "Erreur inconnue. (Impossible de
lister la collection racine.)" 
kmail2(5244): Error while fetching items.  103 "Erreur inconnue. (Impossible de
lister la collection racine.)" 
kmail2(5244): Error while fetching items.  103 "Erreur inconnue. (Impossible de
lister la collection racine.)" 
kmail2(5244): Error while fetching items.  103 "Erreur inconnue. (Impossible de
lister la collection racine.)" 
kmail2(5244): Error while fetching items.  103 "Erreur inconnue. (Impossible de
lister la collection racine.)" 



Reproducible: Always

Steps to Reproduce:
This is very much related to my settings, I suppose.
I don't know how you could reproduce this, probably create a Kmail maildir from
a maildir with a lot of mails, under KDE 4.7.2. Then upgrade.
I still use Soprano 4.7.2

Actual Results:  
When I click on a mail, I get the soprano errors and the Fetching mail screen.
Then suddenly, I get the "Error when fetching item" message repeated several
times and then the mail content is displayed. This occurs about 10 minutes
after clicking on the mail. After that, I seem not to be able to view any other
mail from that folder.

Expected Results:  
Viewing my mail instantly.

-- 
Configure bugmail: https://bugs.kde.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.


More information about the Kdepim-bugs mailing list