[Bug 236732] New: Most attachment actions for encrypted attachments don't work

Thomas McGuire mcguire at kde.org
Fri May 7 18:54:59 CEST 2010


           Summary: Most attachment actions for encrypted attachments
                    don't work
           Product: kdepim
           Version: unspecified
          Platform: Unlisted Binaries
        OS/Version: Linux
            Status: NEW
          Keywords: akonadi-ports-regression
          Severity: normal
          Priority: NOR
         Component: messageviewer
        AssignedTo: kdepim-bugs at kde.org
        ReportedBy: mcguire at kde.org
                CC: amantia at kde.org
            Blocks: 223438

1. Create a simple mail with a single attachment, activate encryption, and save 
   it as draft (with the "never encrypt drafts" option disabled).
2. View the message in the viewer and decrypt it.
3. The attachment actions don't seem to work:
a) saving the attachment saves a "msg_asc", and not the decrypted attachment
b) Viewing the attachment says" [KMail: Attachment contains binary data. Trying
to show first 0 characters.]". The 0 here indicates something is wrong
c) The attachment properties show "application/octet-stream", which is not the 
   mimetype of the attachment
d) Copying does not seem to do anything
e) Open With seems to work :)
f) Deleting the attachment destroys the MIME structure of the message

Configure bugmail: https://bugs.kde.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

More information about the Kdepim-bugs mailing list