[Bug 230390] New: Messages are not properly deleted from POP3 server

Michael Schuerig michael at schuerig.de
Fri Mar 12 00:55:23 CET 2010


https://bugs.kde.org/show_bug.cgi?id=230390

           Summary: Messages are not properly deleted from POP3 server
           Product: kmail
           Version: 1.13.1
          Platform: unspecified
        OS/Version: Linux
            Status: UNCONFIRMED
          Severity: normal
          Priority: NOR
         Component: general
        AssignedTo: kdepim-bugs at kde.org
        ReportedBy: michael at schuerig.de


Version:           1.13.1 (using 4.4.1 (KDE 4.4.1), Debian packages)
Compiler:          cc
OS:                Linux (i686) release 2.6.32-3-686

Since my upgrade from KDE 4.3.4 to 4.4.1 and the respective versions of KMail,
I'm having trouble with messages not being properly deleted from the POP3
server. As a result, the affected messages are retrieved from the server again
and again on each periodic mail check. This only stops when I delete these
messages from the server by some other means. KMail is configured to
immediately delete fetched messages from the server.

It is not the case that no messages are deleted from the server. Things work
correctly for a period, then suddenly, messages are not deleted properly
anymore and in turn are retrieved endlessly. A way to provoke this behavior is
to suspend the computer and later resume it.

As far as I can tell, enabling or disabling pipelining doesn't have an effect;
the server reports that is supports pipelining. Normally, I'm using SSL, but
with it switched off, I noticed that apparently KMail does send DELE messages,
however they are ineffectual. I've only been able to observe anything after
things already were broken. I've not been able to observe the breaking itself.

This might all sound like the POP3 server is at fault. However, it is a
widely-used server at my ISP, other users I know of don't have similar problems
-- and my trouble started exactly when I updated to KDE 4.4.1.

-- 
Configure bugmail: https://bugs.kde.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.


More information about the Kdepim-bugs mailing list